summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrubert <grubert@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2023-05-17 00:12:59 +0000
committergrubert <grubert@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>2023-05-17 00:12:59 +0000
commit6fd42cb03cc7c5972036665ed164d02c195bcbf2 (patch)
tree2362bb6f6847d5303bc4f0b88a59a1d75ae81c32
parent620dba92270df28da96eeaf96751161e8b6f4136 (diff)
downloaddocutils-6fd42cb03cc7c5972036665ed164d02c195bcbf2.tar.gz
releasing 0.20.1
git-svn-id: https://svn.code.sf.net/p/docutils/code/trunk@9391 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
-rw-r--r--sandbox/infrastructure/releasing-log.txt119
1 files changed, 119 insertions, 0 deletions
diff --git a/sandbox/infrastructure/releasing-log.txt b/sandbox/infrastructure/releasing-log.txt
index 94dd6f51d..4d808f021 100644
--- a/sandbox/infrastructure/releasing-log.txt
+++ b/sandbox/infrastructure/releasing-log.txt
@@ -8,6 +8,125 @@ Releasing
Notes on what happend while releasing.
+Release 0.20.1 (2023-05-17)
+===========================
+
+(follow docs/dev/release.txt)
+
+* Make a clean checkout of svn.code.sf.net/p/docutils/code/trunk/docutils
+ to avoid having development files in the released packages.
+
+* Update RELEASE-NOTES.txt add section ``Release <version>``.
+
+ Consult HISTORY.txt for important changes.
+
+* Change HISTORY.txt title ``Changes Since <previous release>`` to ``Release <version>``.
+
+* Set new version (replace ``<version>`` with the new version indentifier
+ and ``<docutils-repository-root>`` with the dir containing
+ ``HISTORY.txt`` and ``RELEASE-NOTES.txt``)::
+
+ cd <docutils-repository-root>
+ ../sandbox/infrastructure/set_version.sh <version>
+
+ Check what was changed by ``set_version.sh``.
+
+ Run tests ::
+
+ export PYTHONWARNINGS=default
+ python3 test/alltests.py
+
+ or use tox.
+ In case of errors, clearing ``docutils/__pycache__`` may help.
+
+ ``export PYTHONWARNINGS=default`` prints DeprecationWarnings in python3.
+
+* Generate wheel and source-distribution::
+
+ python3.11 setup.py sdist
+ python3.11 setup.py bdist_wheel
+
+* check sdist for html-files in docutils.egg-info.
+* Upload wheel and source to test.pypi::
+
+ python3.11 -m twine upload --repository docutils_testpypi dist/docutils-0.20.1*
+
+ *docutils_testpypi* is a repository configured in .pypirc.
+
+ Test in venv. NOTE use --pre for prereleases::
+
+ python3 -m venv du3 ; cd du3
+ export PYTHONPATH= ; . bin/activate
+
+ python -m pip install --index-url https://test.pypi.org/simple/ --pre --no-deps docutils
+
+ cp -Lr ../docutils-code/docutils/test .
+ python test/alltests.py
+
+ As expected HISTORY fails because it is not in the package.
+
+ python -m pip uninstall docutils
+ deactivate ; cd .. ; rm -r du3
+
+* Commit changes ... the changed version number.
+
+* tag #.# (Note: only directory docutils is copied)::
+
+ svn copy svn+ssh://grubert@svn.code.sf.net/p/docutils/code/trunk/docutils \
+ svn+ssh://grubert@svn.code.sf.net/p/docutils/code/tags/docutils-#.# \
+ -m "tagging release #.#"
+
+* Update your source directory.
+
+ Nothing changed.
+
+* Now upload the same files to pypi::
+
+ python3.11 -m twine upload --repository docutils_pypi dist/docutils-0.20.1*
+
+* Remove previous package from local cache::
+
+ find .cache/pip/wheels -name docutils\*whl -exec rm -v -i {} \;
+
+* and test::
+
+ python3.11 -m venv du3 ; cd du3
+ export PYTHONPATH= ; . bin/activate
+
+ pip install --no-deps docutils
+ cp -Lr ../docutils-code/docutils/test .
+ python test/alltests.py
+
+ python -m pip uninstall docutils
+ deactivate ; cd .. ; rm -r du3
+
+* Notify to docutils-developer and user.
+
+* upload source and generated html to sf-htdocs/#.# ::
+
+ mkdir tmp1
+ cd tmp1
+ tar xzvf ../dist/docutils-#.#.tar.gz
+ cd docutils-#.#/
+ python3 tools/buildhtml.py .
+ find . -name \*.pyc -exec rm -v {} \;
+ find . -name __pycache__ -exec rmdir -v {} \;
+ rm -r docutils.egg-info
+ rsync -e ssh -r -t ./ web.sourceforge.net:/home/project-web/docutils/htdocs/#.#
+
+* Check web/index.txt for necessary corrections.
+* Run sandbox/infrastructure/docutils-update.local to update web-content.
+* Release to sourceforge.
+
+ - Upload docutils-#.#.tar.gz and release notes to sourceforge.
+ - Select docutils-#.#.tar.gz as default for all OS.
+
+* set_version 0.20.2b.dev
+* tox: py3.7 3.8 3.9 3.10 3.11
+* docutils/HISTORY.txt: add title "Changes Since 0.20.1"
+* run sandbox/infrastructure/docutils-update.local
+
+
Release 0.20 (2023-05-09)
=========================