summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog19
-rw-r--r--README.md27
-rw-r--r--dns/version.py2
-rwxr-xr-xsetup.py2
4 files changed, 47 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 296ec28..6768880 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,22 @@
+2016-05-27 Bob Halley <halley@dnspython.org>
+
+ * (Version 1.14.0 released)
+
+ * Add CSYNC RR support
+
+ * Fix bug in LOC which destroyed N/S and E/W distinctions within
+ a degree of the equator or prime merdian respectively.
+
+ * Misc. fixes to deal with fallout from the Python 2 & 3 merge.
+ [issue #156], [issue #157], [issue #158], [issue #159],
+ [issue #160].
+
+ * Running with python optimization on caused issues when
+ stripped docstrings were referenced. [issue #154]
+
+ * dns.zone.from_text() erroneously required the zone to be provided.
+ [issue #153]
+
2016-05-13 Bob Halley <halley@dnspython.org>
* dns/message.py (make_query): Setting any value which implies
diff --git a/README.md b/README.md
index 7e21d76..99b92cb 100644
--- a/README.md
+++ b/README.md
@@ -27,7 +27,32 @@ development by continuing to employ the author :).
## ABOUT THIS RELEASE
-This is dnspython 1.13.0
+This is dnspython 1.14.0
+
+New since 1.13.0:
+
+ CSYNC RRs are now supported.
+
+ dns/message.py (make_query): Setting any value which implies
+ EDNS will turn on EDNS if 'use_edns' has not been specified.
+
+Bugs fixed since 1.13.0:
+
+ TSIG signature algorithm setting was broken by the Python 2
+ and Python 3 code line merge.
+
+ A bug in the LOC RR destroyed N/S and E/W distinctions within
+ a degree of the equator or prime merdian respectively.
+
+ Misc. fixes to deal with fallout from the Python 2 & 3 merge.
+ [issue #156], [issue #157], [issue #158], [issue #159],
+ [issue #160].
+
+ Running with python optimization on caused issues when
+ stripped docstrings were referenced. [issue #154]
+
+ dns.zone.from_text() erroneously required the zone to be provided.
+ [issue #153]
New since 1.12.0:
diff --git a/dns/version.py b/dns/version.py
index 94ab87f..3d97f69 100644
--- a/dns/version.py
+++ b/dns/version.py
@@ -16,7 +16,7 @@
"""dnspython release version information."""
MAJOR = 1
-MINOR = 13
+MINOR = 14
MICRO = 0
RELEASELEVEL = 0x0f
SERIAL = 0
diff --git a/setup.py b/setup.py
index 67287c4..08f7bdc 100755
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@
import sys
from setuptools import setup
-version = '1.13.0'
+version = '1.14.0'
kwargs = {
'name' : 'dnspython',