summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2014-09-01 06:03:01 -0700
committerBob Halley <halley@dnspython.org>2014-09-01 06:03:01 -0700
commite1369c62d14f82b80ef11197a490ace5d43bb3f3 (patch)
tree53a52fde2daddfafc7fa6be072ffe36579edebd2
parentc786b02b5c45252c3b1b2b11b16349d06307c5c4 (diff)
downloaddnspython-e1369c62d14f82b80ef11197a490ace5d43bb3f3.tar.gz
Prep 1.12.0v1.12.0
-rw-r--r--ChangeLog7
-rw-r--r--README42
-rw-r--r--dns/version.py4
-rwxr-xr-xsetup.py2
4 files changed, 49 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index c5b0191..39792fe 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,7 +1,12 @@
-2014-09-01 Bob Halley <halley@nominum.com>
+2014-09-01 Bob Halley <halley@dnspython.org>
* (Version 1.12.0 released)
+2014-08-31 Bob Halley <halley@dnspython.org>
+
+ * The test system can now run the tests without requiring dnspython
+ to be installed.
+
2014-07-24 Bob Halley <halley@dnspython.org>
* The 64-bit version of Python on Windows has sys.maxint set to
diff --git a/README b/README
index 53518f4..932e552 100644
--- a/README
+++ b/README
@@ -22,13 +22,51 @@ development by continuing to employ the author :).
ABOUT THIS RELEASE
-This is dnspython 1.11.1
+This is dnspython 1.12.0
+
+New since 1.11.1:
+
+ Added dns.zone.to_text().
+
+ Added support for "options rotate" in /etc/resolv.conf.
+
+ dns.rdtypes.ANY.DNSKEY now has helpers functions to convert
+ between the numeric form of the flags and a set of
+ human-friendly strings
+
+ The reverse name of an IPv6 mapped IPv4 address is now in the
+ IPv4 reverse namespace.
+
+ The test system can now run the tests without requiring
+ dnspython to be installed.
+
+ Preliminary Elliptic Curve DNSSEC Validation (requires ecdsa module)
+
+Bugs fixed since 1.11.1:
+
+ dnspython raised an exception when reading a masterfile starting
+ with leading whitespace
+
+ dnspython was affected by a python slicing API bug present on
+ 64-bit windows.
+
+ Unicode escaping was applied at the wrong time.
+
+ RRSIG to_text() did not respect the relativize setting.
+
+ APL RRs with zero rdlength were rejected.
+
+ The tokenizer could put back an unescaped token.
+
+ Making a response to a message signed with TSIG was broken.
+
+ The IXFR state machine didn't handle long IXFR diffs.
New since 1.11.0:
Nothing
-Bugs fixed since 1.11.1:
+Bugs fixed since 1.11.0:
dns.resolver.Resolver erroneously referred to 'retry_servfail'
instead of 'self.retry_servfail'.
diff --git a/dns/version.py b/dns/version.py
index c3d305e..c382279 100644
--- a/dns/version.py
+++ b/dns/version.py
@@ -16,8 +16,8 @@
"""dnspython release version information."""
MAJOR = 1
-MINOR = 11
-MICRO = 1
+MINOR = 12
+MICRO = 0
RELEASELEVEL = 0x0f
SERIAL = 0
diff --git a/setup.py b/setup.py
index d431c3e..c9d074c 100755
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@
import sys
from distutils.core import setup
-version = '1.11.1'
+version = '1.12.0'
kwargs = {
'name' : 'dnspython',