summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2020-05-04 12:21:27 -0700
committerBob Halley <halley@dnspython.org>2020-05-04 12:21:27 -0700
commit63aac5fdb04110c74ab85ad9cf52a825fa0b1323 (patch)
tree07f6121f121a81fc42ecd915271c3840efec05cb
parente32403119562d59d30ae5054a31da777d528cb2d (diff)
downloaddnspython-63aac5fdb04110c74ab85ad9cf52a825fa0b1323.tar.gz
start flake8 support
-rw-r--r--.flake82
-rw-r--r--Makefile3
-rw-r--r--pyproject.toml2
3 files changed, 6 insertions, 1 deletions
diff --git a/.flake8 b/.flake8
new file mode 100644
index 0000000..711a1b5
--- /dev/null
+++ b/.flake8
@@ -0,0 +1,2 @@
+[flake8]
+ignore = E741
diff --git a/Makefile b/Makefile
index b013f69..8177b15 100644
--- a/Makefile
+++ b/Makefile
@@ -76,3 +76,6 @@ potest:
potype:
poetry run python -m mypy examples tests dns/*.py
+
+poflake:
+ poetry run flake8 dns
diff --git a/pyproject.toml b/pyproject.toml
index 1e37b89..cd0d7bc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -14,8 +14,8 @@ cryptography = "^2.6"
[tool.poetry.dev-dependencies]
mypy = "^0.770"
-pylint = "^2.5.0"
pytest = "^5.4.1"
+flake8 = "^3.7.9"
[build-system]
requires = ["poetry>=0.12"]