summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@nominum.com>2010-11-23 08:13:19 +0000
committerBob Halley <halley@nominum.com>2010-11-23 08:13:19 +0000
commit32322f9df8f413b0bcbbd4aca0152c5add088147 (patch)
tree66ec0f078525b59b6ec53773ca5e400cb75b58f6
parent1cedfbec964a132f655fa5ce66f1d553ba758fc1 (diff)
downloaddnspython-1.9.2.tar.gz
Fix DNSSEC imports, again!v1.9.2
-rw-r--r--ChangeLog10
-rw-r--r--README14
-rw-r--r--dns/dnssec.py3
-rw-r--r--dns/version.py2
-rwxr-xr-xsetup.py2
-rw-r--r--tests/dnssec.py1
6 files changed, 26 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index de1fe7a..91e69d3 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+2010-11-23 Bob Halley <halley@dnspython.org>
+
+ * (Version 1.9.2 released)
+
+2010-11-23 Bob Halley <halley@dnspython.org>
+
+ * dns/dnssec.py (_need_pycrypto): DSA and RSA are modules, not
+ functions, and I didn't notice because the test suite masked
+ the bug! *sigh*
+
2010-11-22 Bob Halley <halley@dnspython.org>
* (Version 1.9.1 released)
diff --git a/README b/README
index ca6b3a4..d53dac6 100644
--- a/README
+++ b/README
@@ -22,13 +22,23 @@ development by continuing to employ the author :).
ABOUT THIS RELEASE
-This is dnspython 1.9.1
+This is dnspython 1.9.2
+
+New since 1.9.1:
+
+ Nothing.
+
+Bugs fixed since 1.9.1:
+
+ The dns.dnssec module didn't work at all due to missing
+ imports that escaped detection in testing because the test
+ suite also did the imports. The third time is the charm!
New since 1.9.0:
Nothing.
-Bugs fixed since 1.9.0
+Bugs fixed since 1.9.0:
The dns.dnssec module didn't work with DSA due to namespace
contamination from a "from"-style import.
diff --git a/dns/dnssec.py b/dns/dnssec.py
index d2d607d..a595fd4 100644
--- a/dns/dnssec.py
+++ b/dns/dnssec.py
@@ -362,7 +362,8 @@ def _need_pycrypto(*args, **kwargs):
raise NotImplementedError, "DNSSEC validation requires pycrypto"
try:
- import Crypto.PublicKey
+ import Crypto.PublicKey.RSA
+ import Crypto.PublicKey.DSA
import Crypto.Util.number
validate = _validate
validate_rrsig = _validate_rrsig
diff --git a/dns/version.py b/dns/version.py
index 8d20c13..fe0e324 100644
--- a/dns/version.py
+++ b/dns/version.py
@@ -17,7 +17,7 @@
MAJOR = 1
MINOR = 9
-MICRO = 1
+MICRO = 2
RELEASELEVEL = 0x0f
SERIAL = 0
diff --git a/setup.py b/setup.py
index 01fddf7..59bd0eb 100755
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@
import sys
from distutils.core import setup
-version = '1.9.1'
+version = '1.9.2'
kwargs = {
'name' : 'dnspython',
diff --git a/tests/dnssec.py b/tests/dnssec.py
index 7e99d41..b30e847 100644
--- a/tests/dnssec.py
+++ b/tests/dnssec.py
@@ -136,7 +136,6 @@ class DNSSECValidatorTestCase(unittest.TestCase):
if __name__ == '__main__':
import_ok = False
try:
- from Crypto.PublicKey import RSA,DSA
import Crypto.Util.number
import_ok = True
except: