summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAymeric Augustin <aymeric.augustin@m4x.org>2012-01-07 19:05:29 +0000
committerAymeric Augustin <aymeric.augustin@m4x.org>2012-01-07 19:05:29 +0000
commitf46003559cc59d27df7a4926001fd10b84f4ab22 (patch)
tree220a0a0805bba9e8dec985e3d4e7c01e6814abad /setup.py
parentaa5d307da65cb0933172c9640efeb44d94323be5 (diff)
downloaddjango-f46003559cc59d27df7a4926001fd10b84f4ab22.tar.gz
Fixed #17491 -- Honored the version number format expected by distutils. Fixed #11236 too.
git-svn-id: http://code.djangoproject.com/svn/django/trunk@17351 bcc190cf-cafb-0310-a4f2-bffc1f526a37
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 6 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index bf5a6c166e..af18af78ff 100644
--- a/setup.py
+++ b/setup.py
@@ -17,10 +17,10 @@ class osx_install_data(install_data):
self.set_undefined_options('install', ('install_lib', 'install_dir'))
install_data.finalize_options(self)
-if sys.platform == "darwin":
- cmdclasses = {'install_data': osx_install_data}
-else:
- cmdclasses = {'install_data': install_data}
+if sys.platform == "darwin":
+ cmdclasses = {'install_data': osx_install_data}
+else:
+ cmdclasses = {'install_data': install_data}
def fullsplit(path, result=None):
"""
@@ -66,13 +66,11 @@ if len(sys.argv) > 1 and sys.argv[1] == 'bdist_wininst':
file_info[0] = '\\PURELIB\\%s' % file_info[0]
# Dynamically calculate the version based on django.VERSION.
-version = __import__('django').get_version()
-if u'SVN' in version:
- version = ' '.join(version.split(' ')[:-1])
+version = __import__('django').get_distutils_version()
setup(
name = "Django",
- version = version.replace(' ', '-'),
+ version = version,
url = 'http://www.djangoproject.com/',
author = 'Django Software Foundation',
author_email = 'foundation@djangoproject.com',