summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2019-11-04 06:36:10 -0800
committerMariusz Felisiak <felisiak.mariusz@gmail.com>2019-11-04 15:36:10 +0100
commitcff6b14b273244dff7a9764391087a5c68b9324a (patch)
treef7797203c0d5d82f1ead7579869d9fe26abe2e38 /setup.py
parent09a00c60bddc0d811bfcdd054c706ea41243aeb5 (diff)
downloaddjango-cff6b14b273244dff7a9764391087a5c68b9324a.tar.gz
Removed unnecessary EXCLUDE_FROM_PACKAGES from setup.py.
Unnecessary since abc0777b63057e2ff97eee2ff184356051e14c47 where the extension was changed to not be ".py". Also, django.bin doesn't have a __init__.py file, so it is not a package and therefore it's not excluded by this argument.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 9e0611e609..2561fd4a7a 100644
--- a/setup.py
+++ b/setup.py
@@ -52,11 +52,6 @@ if "install" in sys.argv:
break
-EXCLUDE_FROM_PACKAGES = ['django.conf.project_template',
- 'django.conf.app_template',
- 'django.bin']
-
-
# Dynamically calculate the version based on django.VERSION.
version = __import__('django').get_version()
@@ -77,7 +72,7 @@ setup(
'rapid development and clean, pragmatic design.'),
long_description=read('README.rst'),
license='BSD',
- packages=find_packages(exclude=EXCLUDE_FROM_PACKAGES),
+ packages=find_packages(),
include_package_data=True,
scripts=['django/bin/django-admin.py'],
entry_points={'console_scripts': [