summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRamiro Morales <cramm0@gmail.com>2012-10-06 18:40:58 -0300
committerRamiro Morales <cramm0@gmail.com>2012-10-06 18:40:58 -0300
commit2100da9dcdba7a8bc18f6180fd7e61640319b48a (patch)
tree9619385bcabee43cfe443de22e144ddfadc7b870 /setup.py
parent69035b0b1c6e3bd4569070bf0f0c774def397f0d (diff)
downloaddjango-2100da9dcdba7a8bc18f6180fd7e61640319b48a.tar.gz
Ensure we ignore __pycache__ PEP 3174 dirs in a few more places.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 165c5e9f73..333d57ac70 100644
--- a/setup.py
+++ b/setup.py
@@ -67,9 +67,10 @@ if root_dir != '':
django_dir = 'django'
for dirpath, dirnames, filenames in os.walk(django_dir):
- # Ignore dirnames that start with '.'
+ # Ignore PEP 3147 cache dirs and those whose names start with '.'
for i, dirname in enumerate(dirnames):
- if dirname.startswith('.'): del dirnames[i]
+ if dirname.startswith('.') or dirname == '__pycache__':
+ del dirnames[i]
if '__init__.py' in filenames:
packages.append('.'.join(fullsplit(dirpath)))
elif filenames: