summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorTim Graham <timograham@gmail.com>2012-12-15 09:25:54 -0500
committerTim Graham <timograham@gmail.com>2012-12-15 09:25:54 -0500
commit1e5b0fc4d0c8b5b6005dd01359e8e0145a63992a (patch)
treef9dd357b8a300d5c43c7e3aeede2acfe2b73911c /docs
parentb594e4923c20de34a3113f714d12e64e2e0295c8 (diff)
downloaddjango-1e5b0fc4d0c8b5b6005dd01359e8e0145a63992a.tar.gz
Fixed #19344 - Documented how to run django-admin in a virtualenv on Windows.
Thanks Hourann Bosci for the patch.
Diffstat (limited to 'docs')
-rw-r--r--docs/faq/troubleshooting.txt37
-rw-r--r--docs/intro/tutorial01.txt19
2 files changed, 37 insertions, 19 deletions
diff --git a/docs/faq/troubleshooting.txt b/docs/faq/troubleshooting.txt
index f984be4bf5..da286cf4e2 100644
--- a/docs/faq/troubleshooting.txt
+++ b/docs/faq/troubleshooting.txt
@@ -5,6 +5,11 @@ Troubleshooting
This page contains some advice about errors and problems commonly encountered
during the development of Django applications.
+.. _troubleshooting-django-admin-py:
+
+Problems running django-admin.py
+================================
+
"command not found: django-admin.py"
------------------------------------
@@ -13,4 +18,34 @@ installed Django via ``python setup.py``. If it's not on your path, you can
find it in ``site-packages/django/bin``, where ``site-packages`` is a directory
within your Python installation. Consider symlinking to :doc:`django-admin.py
</ref/django-admin>` from some place on your path, such as
-:file:`/usr/local/bin`. \ No newline at end of file
+:file:`/usr/local/bin`.
+
+Script name may differ in distribution packages
+-----------------------------------------------
+
+If you installed Django using a Linux distribution's package manager
+(e.g. ``apt-get`` or ``yum``) ``django-admin.py`` may have been renamed to
+``django-admin``; use that instead.
+
+Mac OS X permissions
+--------------------
+
+If you're using Mac OS X, you may see the message "permission denied" when
+you try to run ``django-admin.py``. This is because, on Unix-based systems like
+OS X, a file must be marked as "executable" before it can be run as a program.
+To do this, open Terminal.app and navigate (using the ``cd`` command) to the
+directory where :doc:`django-admin.py </ref/django-admin>` is installed, then
+run the command ``sudo chmod +x django-admin.py``.
+
+Running virtualenv on Windows
+-----------------------------
+
+If you used virtualenv_ to :ref:`install Django <installing-official-release>`
+on Windows, you may get an ``ImportError`` when you try to run
+``django-admin.py``. This is because Windows does not run the
+Python interpreter from your virtual environment unless you invoke it
+directly. Instead, prefix all commands that use .py files with ``python`` and
+use the full path to the file, like so:
+``python C:\pythonXY\Scripts\django-admin.py``.
+
+.. _virtualenv: http://www.virtualenv.org/
diff --git a/docs/intro/tutorial01.txt b/docs/intro/tutorial01.txt
index 686cb5220c..9419f9c4eb 100644
--- a/docs/intro/tutorial01.txt
+++ b/docs/intro/tutorial01.txt
@@ -53,24 +53,7 @@ code, then run the following command:
django-admin.py startproject mysite
This will create a ``mysite`` directory in your current directory. If it didn't
-work, see :doc:`Troubleshooting </faq/troubleshooting>`.
-
-.. admonition:: Script name may differ in distribution packages
-
- If you installed Django using a Linux distribution's package manager
- (e.g. apt-get or yum) ``django-admin.py`` may have been renamed to
- ``django-admin``. You may continue through this documentation by omitting
- ``.py`` from each command.
-
-.. admonition:: Mac OS X permissions
-
- If you're using Mac OS X, you may see the message "permission denied" when
- you try to run ``django-admin.py startproject``. This is because, on
- Unix-based systems like OS X, a file must be marked as "executable" before it
- can be run as a program. To do this, open Terminal.app and navigate (using
- the ``cd`` command) to the directory where :doc:`django-admin.py
- </ref/django-admin>` is installed, then run the command
- ``sudo chmod +x django-admin.py``.
+work, see :ref:`troubleshooting-django-admin-py`.
.. note::