summaryrefslogtreecommitdiff
path: root/docs/Makefile
diff options
context:
space:
mode:
authorSzczepan Cieślik <szczepan.cieslik@gmail.com>2014-02-22 18:46:31 +0100
committerTim Graham <timograham@gmail.com>2014-03-07 09:29:23 -0500
commita0f252520291924f8fb7cb0d85f1680294508560 (patch)
treeb96dcaf239a80e3d0869381c36b080b609ee7d11 /docs/Makefile
parent8f9c3d05650cd418c57f2ded49ed1acbb5c05e77 (diff)
downloaddjango-a0f252520291924f8fb7cb0d85f1680294508560.tar.gz
Fixed #22141 -- Added a spelling checker for documentation.
Diffstat (limited to 'docs/Makefile')
-rw-r--r--docs/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 21b8a9cbe9..f2502be3a7 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -37,6 +37,8 @@ help:
@echo " changes to make an overview of all changed/added/deprecated items"
@echo " linkcheck to check all external links for integrity"
@echo " doctest to run all doctests embedded in the documentation (if enabled)"
+ @echo " spelling to check for typos in documentation"
+
clean:
-rm -rf $(BUILDDIR)/*
@@ -143,3 +145,9 @@ doctest:
$(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
@echo "Testing of doctests in the sources finished, look at the " \
"results in $(BUILDDIR)/doctest/output.txt."
+
+spelling:
+ $(SPHINXBUILD) -b spelling $(ALLSPHINXOPTS) $(BUILDDIR)/spelling
+ @echo
+ @echo "Check finished. Wrong words can be found in " \
+ "$(BUILDDIR)/spelling/output.txt."