summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Phalip <jphalip@gmail.com>2012-11-21 09:52:09 +0100
committerJulien Phalip <jphalip@gmail.com>2012-11-21 09:52:09 +0100
commit693b8a65ad9ccb14266c08a3831c8e8537d7d83c (patch)
tree003118fca885651810d30eeec99eea86d87a6d7e
parentb781354ad1d57be852c859eed4943ead1f1c994d (diff)
downloaddjango-693b8a65ad9ccb14266c08a3831c8e8537d7d83c.tar.gz
Modified a staticfiles test to use a unicode character that has just one single representation. The previously used character (ş) has two different representations (u'\u015f' and u's\u0327'), which caused spurious failures when the tests were run across multiple platforms (e.g. on a Linux VM hosted on a Mac).
-rw-r--r--tests/regressiontests/staticfiles_tests/tests.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/regressiontests/staticfiles_tests/tests.py b/tests/regressiontests/staticfiles_tests/tests.py
index 69e30613a8..0c8e7db17d 100644
--- a/tests/regressiontests/staticfiles_tests/tests.py
+++ b/tests/regressiontests/staticfiles_tests/tests.py
@@ -58,9 +58,9 @@ class BaseStaticFilesTestCase(object):
testfiles_path = os.path.join(TEST_ROOT, 'apps', 'test', 'static', 'test')
# To make sure SVN doesn't hangs itself with the non-ASCII characters
# during checkout, we actually create one file dynamically.
- self._nonascii_filepath = os.path.join(testfiles_path, 'fi\u015fier.txt')
+ self._nonascii_filepath = os.path.join(testfiles_path, '\u2297.txt')
with codecs.open(self._nonascii_filepath, 'w', 'utf-8') as f:
- f.write("fi\u015fier in the app dir")
+ f.write("\u2297 in the app dir")
# And also create the stupid hidden file to dwarf the setup.py's
# package data handling.
self._hidden_filepath = os.path.join(testfiles_path, '.hidden')
@@ -177,7 +177,7 @@ class TestDefaults(object):
"""
Can find a file with non-ASCII character in an app static/ directory.
"""
- self.assertFileContains('test/fişier.txt', 'fişier in the app dir')
+ self.assertFileContains('test/⊗.txt', '⊗ in the app dir')
def test_camelcase_filenames(self):
"""