summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Tredinnick <malcolm.tredinnick@gmail.com>2007-02-12 00:33:24 +0000
committerMalcolm Tredinnick <malcolm.tredinnick@gmail.com>2007-02-12 00:33:24 +0000
commit22587230977e862a7e87723d538b5b5e48800494 (patch)
tree11e01b7a62d56c952ab52b1c2552dde4d0a24ac1
parenta0c354ee4ed02bb3f958dfb029d29b76e6637952 (diff)
downloaddjango-22587230977e862a7e87723d538b5b5e48800494.tar.gz
Refs #3338 -- Partially fix rpm packaging problems. There is still one issue
remaining with how we construct the version numbers, but this change is useful nonetheless. Patch from Dirk Datzert. git-svn-id: http://code.djangoproject.com/svn/django/trunk@4490 bcc190cf-cafb-0310-a4f2-bffc1f526a37
-rw-r--r--AUTHORS2
-rw-r--r--MANIFEST.in10
-rw-r--r--scripts/rpm-install.sh19
-rw-r--r--setup.cfg1
4 files changed, 27 insertions, 5 deletions
diff --git a/AUTHORS b/AUTHORS
index 7f561116d3..61cdfad074 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -67,6 +67,7 @@ answer newbie questions, and generally made Django that much better:
crankycoder@gmail.com
Matt Croydon <http://www.postneo.com/>
dackze+django@gmail.com
+ Dirk Datzert <dummy@habmalnefrage.de>
Jonathan Daugherty (cygnus) <http://www.cprogrammer.org/>
dave@thebarproject.com
Jason Davies (Esaj) <http://www.jasondavies.com/>
@@ -74,7 +75,6 @@ answer newbie questions, and generally made Django that much better:
deric@monowerks.com
dne@mayonnaise.net
Maximillian Dornseif <md@hudora.de>
- dummy@habmalnefrage.de
Jeremy Dunck <http://dunck.us/>
Andy Dustman <farcepest@gmail.com>
Clint Ecker
diff --git a/MANIFEST.in b/MANIFEST.in
index b5fbb3cb90..11b60bcc14 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,8 +1,10 @@
include AUTHORS
include INSTALL
include LICENSE
+recursive-include docs *
+recursive-include scripts *
recursive-include django/conf/locale *
-recursive-include django/contrib/admin/templates
-recursive-include django/contrib/admin/media
-recursive-include django/contrib/comments/templates
-recursive-include django/contrib/sitemaps/templates
+recursive-include django/contrib/admin/templates *
+recursive-include django/contrib/admin/media *
+recursive-include django/contrib/comments/templates *
+recursive-include django/contrib/sitemaps/templates *
diff --git a/scripts/rpm-install.sh b/scripts/rpm-install.sh
new file mode 100644
index 0000000000..07a087c447
--- /dev/null
+++ b/scripts/rpm-install.sh
@@ -0,0 +1,19 @@
+#! /bin/sh
+#
+# this file is *inserted* into the install section of the generated
+# spec file
+#
+
+# this is, what dist.py normally does
+python setup.py install --root=${RPM_BUILD_ROOT} --record="INSTALLED_FILES"
+
+for i in `cat INSTALLED_FILES`; do
+ if [ -f ${RPM_BUILD_ROOT}/$i ]; then
+ echo $i >>FILES
+ fi
+ if [ -d ${RPM_BUILD_ROOT}/$i ]; then
+ echo %dir $i >>DIRS
+ fi
+done
+
+cat DIRS FILES >INSTALLED_FILES
diff --git a/setup.cfg b/setup.cfg
index d3d908abf5..ce9779aa00 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,4 @@
[bdist_rpm]
doc_files = docs/*.txt
+install-script = scripts/rpm-install.sh