summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRocky Meza <rocky@fusionbox.com>2014-02-03 19:57:19 -0700
committerRocky Meza <rocky@fusionbox.com>2014-02-03 19:57:19 -0700
commit7ecf33d1ddebf8a71f386a8bb7f3e30b77575580 (patch)
tree3e9a64f587baa94fc44b157f8dbd854a1aa78a2f
parenta5b2129280c30490a80c07fec5dd805f7bf6b53f (diff)
downloaddjango-pyscss-7ecf33d1ddebf8a71f386a8bb7f3e30b77575580.tar.gz
Added Travis CI
-rw-r--r--.travis.yml21
-rw-r--r--README.rst4
2 files changed, 25 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..4959b2c
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,21 @@
+language: python
+python:
+ - "2.7"
+ - "2.6"
+ - "3.3"
+env:
+ - DJANGO_PACKAGE='Django>=1.5,<1.6'
+ - DJANGO_PACKAGE='Django>=1.6,<1.7'
+matrix:
+ include:
+ - python: "2.6"
+ env: DJANGO_PACKAGE='Django>=1.3,<1.4'
+ - python: "2.6"
+ env: DJANGO_PACKAGE='Django>=1.4,<1.5'
+ - python: "2.7"
+ env: DJANGO_PACKAGE='Django>=1.4,<1.5'
+install:
+ - pip install -q $DJANGO_PACKAGE --use-mirrors
+ - pip install --use-mirrors .
+script:
+ - python setup.py test
diff --git a/README.rst b/README.rst
index 0d23bb1..7c57901 100644
--- a/README.rst
+++ b/README.rst
@@ -3,6 +3,10 @@ django-pyscss
A collection of tools for making it easier to use pyScss within Django.
+.. image:: https://travis-ci.org/fusionbox/django-pyscss.png
+ :target: http://travis-ci.org/fusionbox/django-pyscss
+ :alt: Build Status
+
Why do we need this?
====================