summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRocky Meza <rocky@fusionbox.com>2015-04-22 16:17:36 -0600
committerRocky Meza <rocky@fusionbox.com>2015-04-22 16:17:36 -0600
commit4bb75bbc2dd11d53946593e92a28c15d497eee70 (patch)
treeb59f773324d35f6257c5ed3572ce06155faa28b8
parent518098530e4ab9c2f33303ba00f34a1575c7ba3c (diff)
downloaddjango-pyscss-4bb75bbc2dd11d53946593e92a28c15d497eee70.tar.gz
Add changes for 2.0.0
-rw-r--r--CHANGELOG.rst31
-rw-r--r--setup.py2
2 files changed, 31 insertions, 2 deletions
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index 2c863c7..96b7270 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -5,7 +5,36 @@ CHANGELOG
2.0.0 (unreleased)
==================
-- Nothing changed yet.
+- Added support for pyScss 1.3 and Python 3.
+- Dropped support for pyScss 1.2
+
+Upgrade path
+^^^^^^^^^^^^
+
+If you are just using the django-compressor integration, you don't have to
+upgrade anything.
+
+If you were using the ``DjangoScss`` class directly, it has been replaced with
+the ``DjangoScssCompiler`` class. The API for compiling CSS has changed as
+well, for example, to compile from a string, previously you would do it like
+this:
+
+.. code-block:: python
+
+ >>> from django_pyscss.scss import DjangoScss
+ >>> compiler = DjangoScss()
+ >>> compiler.compile(".foo { color: red; }")
+
+Now the interface is like this:
+
+.. code-block:: python
+
+ >>> from django_pyscss import DjangoScssCompiler
+ >>> compiler = DjangoScssCompiler()
+ >>> compiler.compile_string(".foo { color: red; }")
+
+You read more about the new API on the `pyScss API documentation
+<http://pyscss.readthedocs.org/en/latest/python-api.html#new-api>`_.
1.0.0 - 2014-02-11
diff --git a/setup.py b/setup.py
index 1c15cb3..13cad12 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ setup(
url="https://github.com/fusionbox/django-pyscss",
keywords="django css scss sass pyscss compressor",
description=__doc__,
- long_description=read('README.rst'),
+ long_description=read('README.rst') + '\n\n' + read('CHANGELOG.rst'),
packages=[package for package in find_packages() if package.startswith('django_pyscss')],
install_requires=install_requires,
tests_require=tests_require,