summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRocky Meza <rocky@fusionbox.com>2014-02-08 09:20:19 -0700
committerRocky Meza <rocky@fusionbox.com>2014-02-08 09:29:18 -0700
commit3d1b55130aa3acca2a4763451f17ce389489a3e2 (patch)
treed80b825fb230cb4d3b87b9770e1498d930fcd0f5
parent7cf59ff9f680cd48837562c315f95a0bf0a64967 (diff)
downloaddjango-pyscss-3d1b55130aa3acca2a4763451f17ce389489a3e2.tar.gz
Added coveralls.
-rw-r--r--.travis.yml5
-rw-r--r--README.rst4
2 files changed, 8 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 578a7ed..31cae4a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -15,5 +15,8 @@ matrix:
install:
- pip install -q $DJANGO_PACKAGE --use-mirrors
- pip install --use-mirrors .
+ - pip install coveralls
script:
- - python setup.py test
+ - coverage run --source=django_pyscss setup.py test
+after_success:
+ coveralls
diff --git a/README.rst b/README.rst
index 7c57901..beb5f46 100644
--- a/README.rst
+++ b/README.rst
@@ -7,6 +7,10 @@ A collection of tools for making it easier to use pyScss within Django.
:target: http://travis-ci.org/fusionbox/django-pyscss
:alt: Build Status
+.. image:: https://coveralls.io/repos/fusionbox/django-pyscss/badge.png?branch=master
+ :target: https://coveralls.io/r/fusionbox/django-pyscss
+ :alt: Coverage Status
+
Why do we need this?
====================