summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/ci.yml9
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 12 insertions, 0 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 49a4223..325a976 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -36,6 +36,15 @@ jobs:
- python: "3.11"
toxenv: py311-4.1.X
+ - python: 3.8
+ toxenv: py38-4.2.X
+ - python: 3.9
+ toxenv: py39-4.2.X
+ - python: "3.10"
+ toxenv: py310-4.2.X
+ - python: "3.11"
+ toxenv: py311-4.2.X
+
runs-on: ubuntu-latest
steps:
- uses: actions/checkout@v3
diff --git a/setup.py b/setup.py
index 3a5044e..fb62876 100644
--- a/setup.py
+++ b/setup.py
@@ -149,6 +149,7 @@ setup(
"Framework :: Django :: 3.2",
"Framework :: Django :: 4.0",
"Framework :: Django :: 4.1",
+ "Framework :: Django :: 4.2",
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
"Operating System :: OS Independent",
diff --git a/tox.ini b/tox.ini
index da0a67e..8bd1f0f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,6 +3,7 @@ envlist =
{py38,py39,py310}-3.2.X
{py38,py39,py310}-4.0.X
{py38,py39,py310,py311}-4.1.X
+ {py38,py39,py310,py311}-4.2.X
[testenv]
basepython =
py38: python3.8
@@ -20,4 +21,5 @@ deps =
3.2.X: Django>=3.2,<4.0
4.0.X: Django>=4.0,<4.1
4.1.X: Django>=4.1,<4.2
+ 4.2.X: Django>=4.2,<5.0
-r{toxinidir}/requirements/tests.txt