summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Pillard <mpillard@mozilla.com>2023-01-22 13:02:49 +0100
committerMathieu Pillard <mpillard@mozilla.com>2023-01-22 13:06:05 +0100
commit01c1d50ac0f69c11e5f4e3aaa441c35e03e6b9a6 (patch)
tree63410a3d287a54df85d635da5432d7cd61dcf05d
parentcf44bfb715e7b71657c30a6dc35fc8bc68a7a977 (diff)
downloaddjango-compressor-01c1d50ac0f69c11e5f4e3aaa441c35e03e6b9a6.tar.gz
Doc fixes, prepare 4.3.1
-rw-r--r--compressor/__init__.py2
-rw-r--r--docs/behind-the-scenes.txt2
-rw-r--r--docs/changelog.txt46
-rw-r--r--docs/quickstart.txt2
-rw-r--r--docs/settings.txt5
-rw-r--r--setup.py7
6 files changed, 39 insertions, 25 deletions
diff --git a/compressor/__init__.py b/compressor/__init__.py
index e589326..690df3b 100644
--- a/compressor/__init__.py
+++ b/compressor/__init__.py
@@ -1,2 +1,2 @@
# following PEP 386
-__version__ = "4.3"
+__version__ = "4.3.1"
diff --git a/docs/behind-the-scenes.txt b/docs/behind-the-scenes.txt
index 047d886..ddc960e 100644
--- a/docs/behind-the-scenes.txt
+++ b/docs/behind-the-scenes.txt
@@ -9,7 +9,7 @@ The goal is to explain what the main template tag, {% compress %}, does
behind the scenes, to help you debug performance problems for instance.
Offline compression
--------------
+-------------------
If offline compression is activated, the {% compress %} tag will try to
retrieve the compressed version for its nodelist from the offline manifest
diff --git a/docs/changelog.txt b/docs/changelog.txt
index dee3fb0..48f7e15 100644
--- a/docs/changelog.txt
+++ b/docs/changelog.txt
@@ -1,17 +1,25 @@
Changelog
=========
+v4.3.1 (2023-01-22)
+-------------------
+
+`Full list of changes from v4.3 <https://github.com/django-compressor/django-compressor/compare/4.3...4.3.1>`_
+
+- Documentation fixes only
+
+
v4.3 (2023-01-06)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/4.2...4.3>`_
+`Full list of changes from v4.2 <https://github.com/django-compressor/django-compressor/compare/4.2...4.3>`_
- Officially support Python 3.11
v4.2 (2023-01-06)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/4.1...4.2>`_
+`Full list of changes from v4.1 <https://github.com/django-compressor/django-compressor/compare/4.1...4.2>`_
- Drop Python 3.6 and 3.7 support
- Drop Django 2.2 and 3.1 support
@@ -25,7 +33,7 @@ v4.2 (2023-01-06)
v4.1 (2022-08-03)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/4.0...4.1>`_
+`Full list of changes from v4.0 <https://github.com/django-compressor/django-compressor/compare/4.0...4.1>`_
- Add Django 4.1 compatibility
@@ -39,7 +47,7 @@ v4.1 (2022-08-03)
v4.0 (2022-03-23)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/3.1...4.0>`_
+`Full list of changes from v3.1 <https://github.com/django-compressor/django-compressor/compare/3.1...4.0>`_
- Fix intermittent No such file or directory errors by changing strategy to
deal with duplicate filenames in CompressorFileStorage
@@ -55,7 +63,7 @@ v4.0 (2022-03-23)
v3.1 (2021-12-18)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/3.0...3.1>`_
+`Full list of changes from v3.0 <https://github.com/django-compressor/django-compressor/compare/3.0...3.1>`_
- Fix error with verbose offline compression when COMPRESS_OFFLINE_CONTEXT is a generator
@@ -63,7 +71,7 @@ v3.1 (2021-12-18)
v3.0 (2021-12-12)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/2.4.1...3.0>`_
+`Full list of changes from v2.4.1 <https://github.com/django-compressor/django-compressor/compare/2.4.1...3.0>`_
- Officially support Python 3.9 and 3.10 as well as Django 3.1, 3.2 and 4.0
- Drop support for Django 1.11, 2.1 and 3.0
@@ -81,7 +89,7 @@ v3.0 (2021-12-12)
v2.4.1 (2021-04-17)
-------------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/2.4...2.4.1>`_
+`Full list of changes from v2.4 <https://github.com/django-compressor/django-compressor/compare/2.4...2.4.1>`_
- Raise proper ``DeprecationWarning`` for ``COMPRESS_JS_FILTERS`` and ``COMPRESS_CSS_FILTERS``
@@ -89,7 +97,7 @@ v2.4.1 (2021-04-17)
v2.4 (2019-12-31)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/2.3...2.4>`_
+`Full list of changes from v2.3 <https://github.com/django-compressor/django-compressor/compare/2.3...2.4>`_
- Add support for Django 3.0 (#950, #967)
- Officially support Python 3.8 (#967)
@@ -102,7 +110,7 @@ Note: in 2.3, a new setting ``COMPRESS_FILTERS`` has been introduced that combin
v2.3 (2019-05-31)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/2.2...2.3>`_
+`Full list of changes from v2.2 <https://github.com/django-compressor/django-compressor/compare/2.2...2.3>`_
- Drop support for Django 1.8, 1.9 and 1.10
- Add support for Django 2.1 and 2.2, as well as Python 3.7
@@ -119,7 +127,7 @@ v2.3 (2019-05-31)
v2.2 (2017-08-16)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/2.1.1...2.2>`_
+`Full list of changes from v2.1.1 <https://github.com/django-compressor/django-compressor/compare/2.1.1...2.2>`_
- Switch from MD5 to SHA256 for hashes generation.
@@ -138,13 +146,15 @@ v2.2 (2017-08-16)
v2.1.1 (2017-02-02)
-------------------
+`Full list of changes from v2.1 <https://github.com/django-compressor/django-compressor/compare/2.1...2.1.1>`_
+
- Fix to file permissions issue with packaging.
v2.1 (2016-08-09)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/2.0...2.1>`_
+`Full list of changes from v2.0 <https://github.com/django-compressor/django-compressor/compare/2.0...2.1>`_
- Add Django 1.10 compatibility
@@ -160,7 +170,7 @@ v2.1 (2016-08-09)
v2.0 (2016-01-07)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/1.6...2.0>`_
+`Full list of changes from v1.6 <https://github.com/django-compressor/django-compressor/compare/1.6...2.0>`_
- Add Django 1.9 compatibility
@@ -186,7 +196,7 @@ v2.0 (2016-01-07)
v1.6 (2015-11-19)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/1.5...1.6>`_
+`Full list of changes from v1.5 <https://github.com/django-compressor/django-compressor/compare/1.5...1.6>`_
- Upgrade rcssmin and rjsmin
@@ -208,7 +218,7 @@ v1.6 (2015-11-19)
v1.5 (2015-03-27)
-----------------
-`Full Changelog <https://github.com/django-compressor/django-compressor/compare/1.4...1.5>`_
+`Full list of changes from v1.4 <https://github.com/django-compressor/django-compressor/compare/1.4...1.5>`_
- Fix compress command and run automated tests for Django 1.8
@@ -407,9 +417,8 @@ v1.1
- Made offline compression completely independent from cache (by writing a
manifest.json file).
- You can now easily run the :ref:`compress <pre-compression>` management
- command locally and transfer the :attr:`~django.conf.settings.COMPRESS_ROOT`
- dir to your server.
+ You can now easily run the ``compress`` management command locally and
+ transfer the :attr:`~django.conf.settings.COMPRESS_ROOT` dir to your server.
- Updated installation instructions to properly mention all dependencies,
even those internally used.
@@ -595,8 +604,7 @@ Major improvements and a lot of bugfixes, some of which are:
those together with compressor.
- New ``compress`` management command which allows pre-running of what the
- compress template tag does. See the
- :ref:`pre-compression <pre-compression>` docs for more information.
+ compress template tag does.
- Various performance improvements by better caching and mtime cheking.
diff --git a/docs/quickstart.txt b/docs/quickstart.txt
index f6f23a4..829ff9c 100644
--- a/docs/quickstart.txt
+++ b/docs/quickstart.txt
@@ -40,7 +40,7 @@ Installation
.. _dependencies:
Optional Dependencies
-------------
+---------------------
- BeautifulSoup_
diff --git a/docs/settings.txt b/docs/settings.txt
index 8a706f7..d685d64 100644
--- a/docs/settings.txt
+++ b/docs/settings.txt
@@ -226,10 +226,12 @@ Backend settings
A filter that passes the JavaScript code to the `YUI compressor`_.
.. attribute:: COMPRESS_YUI_BINARY
+ :noindex:
The YUI compressor filesystem path.
.. attribute:: COMPRESS_YUI_JS_ARGUMENTS
+ :noindex:
The arguments passed to the compressor.
@@ -238,10 +240,12 @@ Backend settings
A filter that passes the JavaScript code to the `yUglify compressor`_.
.. attribute:: COMPRESS_YUGLIFY_BINARY
+ :noindex:
The yUglify compressor filesystem path.
.. attribute:: COMPRESS_YUGLIFY_JS_ARGUMENTS
+ :noindex:
The arguments passed to the compressor.
@@ -250,6 +254,7 @@ Backend settings
A filter that renders the JavaScript code with Django templating system.
.. attribute:: COMPRESS_TEMPLATE_FILTER_CONTEXT
+ :noindex:
The context to render your JavaScript code with.
diff --git a/setup.py b/setup.py
index 4be7467..3a5044e 100644
--- a/setup.py
+++ b/setup.py
@@ -136,10 +136,11 @@ setup(
"Source": "https://github.com/django-compressor/django-compressor",
},
license="MIT",
- description="Compresses linked and inline JavaScript or CSS into single cached files.",
+ description=(
+ "Compresses linked and inline JavaScript or CSS into single cached files.",
+ ),
long_description=read("README.rst"),
- author="Jannis Leidel",
- author_email="jannis@leidel.info",
+ maintainer="Mathieu Pillard",
packages=find_packages(),
package_data=find_package_data(),
classifiers=[