summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Pillard <mpillard@mozilla.com>2022-10-14 00:32:45 +0200
committerMathieu Pillard <mpillard@mozilla.com>2022-10-14 00:34:09 +0200
commit7b6c3336eebd41a2ae32d901dbe34f8cd01eb400 (patch)
treeff33d7f3d1a74bb910fe9ee38ec909b804d8aaad
parentff512ee0c4fdb30e48f5da882fb6a074533cf42f (diff)
downloaddjango-compressor-drop-python-3.6.tar.gz
Drop Python 3.6 supportdrop-python-3.6
-rw-r--r--.github/workflows/ci.yml6
-rw-r--r--docs/changelog.txt1
-rw-r--r--setup.py1
-rw-r--r--tox.ini7
4 files changed, 4 insertions, 11 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index d170520..519ba37 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -13,8 +13,6 @@ jobs:
fail-fast: false
matrix:
versions:
- - python: 3.6
- toxenv: py36-2.2.X
- python: 3.7
toxenv: py37-2.2.X
- python: 3.8
@@ -22,8 +20,6 @@ jobs:
- python: 3.9
toxenv: py39-2.2.X
- - python: 3.6
- toxenv: py36-3.1.X
- python: 3.7
toxenv: py37-3.1.X
- python: 3.8
@@ -31,8 +27,6 @@ jobs:
- python: 3.9
toxenv: py39-3.1.X
- - python: 3.6
- toxenv: py36-3.2.X
- python: 3.7
toxenv: py37-3.2.X
- python: 3.8
diff --git a/docs/changelog.txt b/docs/changelog.txt
index 55aaceb..71c0c0f 100644
--- a/docs/changelog.txt
+++ b/docs/changelog.txt
@@ -4,6 +4,7 @@ Changelog
Unreleased
----------
+- Drop Python 3.6 support
- Update the `CachedS3Boto3Storage` example storage subclass in "Remote Storages"
to work properly after the v4.0 change to how duplicate file names are handled
by `CompressorFileStorage`
diff --git a/setup.py b/setup.py
index 958769f..946d091 100644
--- a/setup.py
+++ b/setup.py
@@ -139,7 +139,6 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 3 :: Only',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
diff --git a/tox.ini b/tox.ini
index 5e48582..a34e066 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,13 +1,12 @@
[tox]
envlist =
- {py36,py37,py38,py39}-2.2.X
- {py36,py37,py38,py39}-3.1.X
- {py36,py37,py38,py39,py310}-3.2.X
+ {py37,py38,py39}-2.2.X
+ {py37,py38,py39}-3.1.X
+ {py37,py38,py39,py310}-3.2.X
{py38,py39,py310}-4.0.X
{py38,py39,py310}-4.1.X
[testenv]
basepython =
- py36: python3.6
py37: python3.7
py38: python3.8
py39: python3.9