summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlton Gibson <carlton.gibson@noumenal.es>2023-01-06 16:23:07 +0100
committerCarlton Gibson <carlton@noumenal.es>2023-01-06 16:26:53 +0100
commite58ddb5aa51b2b7a8fe9dfee9e9cbfb35bc327c4 (patch)
treedf3c06b1a1be35313360d5392b1b94ef29ad9622
parentd0726728bfb9cec645ee864996bad454f6354b9d (diff)
downloaddjango-appconf-e58ddb5aa51b2b7a8fe9dfee9e9cbfb35bc327c4.tar.gz
Updated supported versions and CI matrix.
-rw-r--r--.github/workflows/tests.yml32
-rw-r--r--setup.py8
-rw-r--r--tests/test_settings.py1
-rw-r--r--tox.ini24
4 files changed, 34 insertions, 31 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index cd4923b..954e254 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -1,5 +1,11 @@
name: Run Tests
-on: [push]
+
+on:
+ push:
+ branches:
+ - main
+ pull_request:
+
jobs:
tests:
name: Python ${{ matrix.python-version }}
@@ -8,21 +14,27 @@ jobs:
fail-fast: false
matrix:
python-version:
- - 3.6
- - 3.7
- - 3.8
- - 3.9
+ - "3.7"
+ - "3.8"
+ - "3.9"
+ - "3.10"
+ - "3.11"
+
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
+
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
+
- name: Install dependencies
run: |
python -m pip install --upgrade pip wheel setuptools
- python -m pip install --upgrade tox tox-py coverage
+ python -m pip install --upgrade tox
+
- name: Run tox targets for ${{ matrix.python-version }}
- run: tox --py current
+ run: tox run -f py$(echo ${{ matrix.python-version }} | tr -d .)
+
- name: codecov
- uses: codecov/codecov-action@v2 \ No newline at end of file
+ uses: codecov/codecov-action@v2
diff --git a/setup.py b/setup.py
index 6613883..a430912 100644
--- a/setup.py
+++ b/setup.py
@@ -29,24 +29,24 @@ setup(
license='BSD',
url='https://django-appconf.readthedocs.io/',
packages=['appconf'],
- python_requires='>=3.6',
+ python_requires='>=3.7',
install_requires=['django'],
classifiers=[
'Development Status :: 5 - Production/Stable',
'Environment :: Web Environment',
'Framework :: Django',
- 'Framework :: Django :: 2.2',
- 'Framework :: Django :: 3.1',
'Framework :: Django :: 3.2',
'Framework :: Django :: 4.0',
+ 'Framework :: Django :: 4.1',
'Intended Audience :: Developers',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Programming Language :: Python :: 3 :: Only',
'Topic :: Utilities',
],
diff --git a/tests/test_settings.py b/tests/test_settings.py
index 6d420a2..4591744 100644
--- a/tests/test_settings.py
+++ b/tests/test_settings.py
@@ -33,6 +33,7 @@ TEMPLATES = [
"context_processors": [
"django.contrib.auth.context_processors.auth",
"django.contrib.messages.context_processors.messages",
+ "django.template.context_processors.request",
]
},
}
diff --git a/tox.ini b/tox.ini
index d95783d..9ad5f30 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,37 +1,27 @@
[tox]
-skipsdist = True
-usedevelop = True
-minversion = 1.11
envlist =
- flake8-py39,
- py{36,37,38,39}-dj{22,31,32},
- py{38,39}-dj{40,main}
+ flake8-py311,
+ py{37,38,39,310}-dj32
+ py{38,39,310,311}-dj{40,41,main}
[testenv]
-basepython =
- py36: python3.6
- py37: python3.7
- py38: python3.8
- py39: python3.9
- pypy: pypy
usedevelop = true
setenv =
PYTHONPATH = {toxinidir}
DJANGO_SETTINGS_MODULE=tests.test_settings
deps =
- py{35,36,37,38,39,pypy}: coverage
+ py{37,38,39,310,311}: coverage
django-discover-runner
- dj22: Django>=2.2,<3.0
- dj31: Django>=3.1,<3.2
dj32: Django>=3.2,<4.0
- dj40: Django>=4.0a1,<5.0
+ dj40: Django>=4.0,<4.1
+ dj41: Django>=4.1,<4.2
djmain: https://github.com/django/django/archive/main.tar.gz#egg=django
commands =
coverage run {envbindir}/django-admin test -v2 {posargs:tests}
coverage report
-[testenv:flake8-py39]
+[testenv:flake8-py311]
commands = flake8 appconf
deps = flake8