summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt9
-rw-r--r--defusedxml/__init__.py4
-rw-r--r--setup.py2
3 files changed, 9 insertions, 6 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 872ca3c..214c562 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,10 +1,13 @@
Changelog
=========
-defusedxml 0.5
---------------
+defusedxml 0.4.1
+----------------
+
+*Release date: 28-Mar-2013*
-*Release date: ??-???-2013*
+- Add more demo exploits, e.g. python_external.py and Xalan XSLT demos.
+- Improved documentation.
defusedxml 0.4
diff --git a/defusedxml/__init__.py b/defusedxml/__init__.py
index 247f542..98a7f14 100644
--- a/defusedxml/__init__.py
+++ b/defusedxml/__init__.py
@@ -14,7 +14,7 @@ from .common import (DefusedXmlException, DTDForbidden, EntitiesForbidden,
def defuse_stdlib():
"""Monkey patch and defuse all stdlib packages
- :warning: It's an HIGHLY EXPERIMETNAL and hardly tested feature.
+ :warning: The monkey patch is an EXPERIMETNAL feature.
"""
defused = {}
@@ -38,5 +38,5 @@ def defuse_stdlib():
return defused
-__version__ = "0.5dev"
+__version__ = "0.4.1"
diff --git a/setup.py b/setup.py
index 82413e4..9fc47c1 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
description="XML bomb protection for Python stdlib modules",
long_description="\n".join(long_description),
classifiers=[
- "Development Status :: 4 - Beta",
+ "Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"License :: OSI Approved :: Python Software Foundation License",
"Natural Language :: English",