summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-10-06 18:28:50 +0200
committerChristian Heimes <christian@python.org>2021-10-06 19:46:16 +0300
commit3284a14b16efb5270ec33c51c468a497127b6a7b (patch)
tree5b930845cbcae9df448c5d64007afbab01aaba74
parent9ca12a2cd3faf4554b30ac7d380a4ea393469c72 (diff)
downloaddefusedxml-git-3284a14b16efb5270ec33c51c468a497127b6a7b.tar.gz
Officially support Python 3.10
Signed-off-by: Christian Heimes <christian@python.org>
-rw-r--r--.github/workflows/main.yml7
-rw-r--r--CHANGES.txt1
-rw-r--r--setup.py1
3 files changed, 8 insertions, 1 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 7ae7a6a..93ab2c8 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -18,7 +18,12 @@ jobs:
strategy:
fail-fast: false
matrix:
- python-version: ["3.6", "3.7", "3.8", "3.9"]
+ python-version:
+ - "3.6"
+ - "3.7"
+ - "3.8"
+ - "3.9"
+ - "3.10"
steps:
- uses: "actions/checkout@v2"
- uses: "actions/setup-python@v2"
diff --git a/CHANGES.txt b/CHANGES.txt
index 6d8c34d..45cc4a5 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -5,6 +5,7 @@ defusedxml 0.8.0.dev1
---------------------
- Drop support for Python 2.7, 3.4, and 3.5.
+- Officially support Python 3.10.
- Add ``defusedxml.ElementTree.fromstringlist()``
- Fix regression ``defusedxml.ElementTree.ParseError`` (#63)
The ``ParseError`` exception is now the same class object as
diff --git a/setup.py b/setup.py
index fa459f5..7636ab4 100644
--- a/setup.py
+++ b/setup.py
@@ -56,6 +56,7 @@ setup(
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Topic :: Text Processing :: Markup :: XML",
],
python_requires=">=3.6",