summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomi Pieviläinen <tomi.pievilainen+launchpad@iki.fi>2012-03-28 18:49:19 +0300
committerTomi Pieviläinen <tomi.pievilainen+launchpad@iki.fi>2012-03-28 18:49:19 +0300
commit691a3ccf8f1bf6e01f6cd948abdd44b916440446 (patch)
tree8e6c75d312641dda473f32e35a35698a1e7520ee
parente5515075578b4dce946e22a80ed87041405512ba (diff)
downloaddateutil-691a3ccf8f1bf6e01f6cd948abdd44b916440446.tar.gz
Preparing for release
-rw-r--r--NEWS8
-rwxr-xr-xsetup.py8
2 files changed, 9 insertions, 7 deletions
diff --git a/NEWS b/NEWS
index f6915f4..3a0a8ed 100644
--- a/NEWS
+++ b/NEWS
@@ -1,11 +1,11 @@
-Version 2.1pre
---------------
+Version 2.1
+-----------
- New maintainer
-- Dateutil now works on Python 2.6, 2.7 and 3.2 fomr same codebase (with six)
+- Dateutil now works on Python 2.6, 2.7 and 3.2 from same codebase (with six)
-- https://launchpad.net/bugs/704047: Ismael Carnales' patch for a new time format
+- #704047: Ismael Carnales' patch for a new time format
- Small bug fixes, thanks for reporters!
diff --git a/setup.py b/setup.py
index a83903f..c195e78 100755
--- a/setup.py
+++ b/setup.py
@@ -29,7 +29,9 @@ The dateutil module provides powerful extensions to the
datetime module available in the Python standard library.
""",
packages = ["dateutil", "dateutil.zoneinfo"],
- package_data={"": ["*.tar.gz"]},
- include_package_data=True,
- zip_safe=False,
+ package_data = {"": ["*.tar.gz"]},
+ include_package_data = True,
+ zip_safe = False,
+ requires = ["six"],
+ install_requires = ["six"], # XXX fix when packaging is sane again
)