summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomi Pieviläinen <tomi.pievilainen+launchpad@iki.fi>2012-03-28 12:01:47 +0300
committerTomi Pieviläinen <tomi.pievilainen+launchpad@iki.fi>2012-03-28 12:01:47 +0300
commit4e5cd8f57f07f634411034a1571c23decb15aad1 (patch)
tree9d4916230000416923b73abce8fda59b804a5b52
parent15fc1fa8c1e2c3d088e646d6d47ac9d25d902f95 (diff)
parent40996e01996096f252ef9d7754edf054e691900d (diff)
downloaddateutil-4e5cd8f57f07f634411034a1571c23decb15aad1.tar.gz
Merge license fixes
-rw-r--r--LICENSE3
-rw-r--r--README2
-rw-r--r--dateutil/__init__.py7
-rw-r--r--dateutil/easter.py3
-rw-r--r--dateutil/parser.py3
-rw-r--r--dateutil/relativedelta.py3
-rw-r--r--dateutil/rrule.py3
-rw-r--r--dateutil/tz.py3
-rw-r--r--dateutil/tzwin.py1
-rw-r--r--dateutil/zoneinfo/__init__.py7
-rw-r--r--sandbox/scheduler.py7
-rwxr-xr-xsetup.py10
-rwxr-xr-xupdatezinfo.py2
13 files changed, 26 insertions, 28 deletions
diff --git a/LICENSE b/LICENSE
index f08c6ad..5834335 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,6 +1,7 @@
-dateutil - Extensions to the standard python 2.3+ datetime module.
+dateutil - Extensions to the standard Python datetime module.
Copyright (c) 2003-2011 - Gustavo Niemeyer <gustavo@niemeyer.net>
+Copyright (c) 2012 - Tomi Pieviläinen <tomi.pievilainen@iki.fi>
All rights reserved.
diff --git a/README b/README
index dbe7988..9453699 100644
--- a/README
+++ b/README
@@ -6,7 +6,7 @@
== Description ==
The '''dateutil''' module provides powerful extensions to
-the standard '''datetime''' module, available in Python 2.3+.
+the standard '''datetime''' module, available in Python.
== Features ==
diff --git a/dateutil/__init__.py b/dateutil/__init__.py
index 1187e3e..0f91a31 100644
--- a/dateutil/__init__.py
+++ b/dateutil/__init__.py
@@ -1,9 +1,10 @@
+# -*- coding: utf-8 -*-
"""
Copyright (c) 2003-2010 Gustavo Niemeyer <gustavo@niemeyer.net>
-This module offers extensions to the standard python 2.3+
+This module offers extensions to the standard Python
datetime module.
"""
-__author__ = "Gustavo Niemeyer <gustavo@niemeyer.net>"
+__author__ = "Tomi Pieviläinen <tomi.pievilainen@iki.fi>"
__license__ = "Simplified BSD"
-__version__ = "2.0"
+__version__ = "2.1"
diff --git a/dateutil/easter.py b/dateutil/easter.py
index cebefcd..d8a3884 100644
--- a/dateutil/easter.py
+++ b/dateutil/easter.py
@@ -1,10 +1,9 @@
"""
Copyright (c) 2003-2007 Gustavo Niemeyer <gustavo@niemeyer.net>
-This module offers extensions to the standard python 2.3+
+This module offers extensions to the standard Python
datetime module.
"""
-__author__ = "Gustavo Niemeyer <gustavo@niemeyer.net>"
__license__ = "Simplified BSD"
import datetime
diff --git a/dateutil/parser.py b/dateutil/parser.py
index b3ac37b..a2604a3 100644
--- a/dateutil/parser.py
+++ b/dateutil/parser.py
@@ -2,11 +2,10 @@
"""
Copyright (c) 2003-2007 Gustavo Niemeyer <gustavo@niemeyer.net>
-This module offers extensions to the standard python 2.3+
+This module offers extensions to the standard Python
datetime module.
"""
from __future__ import unicode_literals
-__author__ = "Gustavo Niemeyer <gustavo@niemeyer.net>"
__license__ = "Simplified BSD"
diff --git a/dateutil/relativedelta.py b/dateutil/relativedelta.py
index 5d09731..4393bcb 100644
--- a/dateutil/relativedelta.py
+++ b/dateutil/relativedelta.py
@@ -1,10 +1,9 @@
"""
Copyright (c) 2003-2010 Gustavo Niemeyer <gustavo@niemeyer.net>
-This module offers extensions to the standard python 2.3+
+This module offers extensions to the standard Python
datetime module.
"""
-__author__ = "Gustavo Niemeyer <gustavo@niemeyer.net>"
__license__ = "Simplified BSD"
import datetime
diff --git a/dateutil/rrule.py b/dateutil/rrule.py
index b65afc0..ad4d3ba 100644
--- a/dateutil/rrule.py
+++ b/dateutil/rrule.py
@@ -1,10 +1,9 @@
"""
Copyright (c) 2003-2010 Gustavo Niemeyer <gustavo@niemeyer.net>
-This module offers extensions to the standard python 2.3+
+This module offers extensions to the standard Python
datetime module.
"""
-__author__ = "Gustavo Niemeyer <gustavo@niemeyer.net>"
__license__ = "Simplified BSD"
import itertools
diff --git a/dateutil/tz.py b/dateutil/tz.py
index e736d58..e1976db 100644
--- a/dateutil/tz.py
+++ b/dateutil/tz.py
@@ -1,10 +1,9 @@
"""
Copyright (c) 2003-2007 Gustavo Niemeyer <gustavo@niemeyer.net>
-This module offers extensions to the standard python 2.3+
+This module offers extensions to the standard Python
datetime module.
"""
-__author__ = "Gustavo Niemeyer <gustavo@niemeyer.net>"
__license__ = "Simplified BSD"
from six import string_types, PY3
diff --git a/dateutil/tzwin.py b/dateutil/tzwin.py
index b378f59..041c6cc 100644
--- a/dateutil/tzwin.py
+++ b/dateutil/tzwin.py
@@ -3,7 +3,6 @@ import datetime
import struct
import winreg
-__author__ = "Jeffrey Harris & Gustavo Niemeyer <gustavo@niemeyer.net>"
__all__ = ["tzwin", "tzwinlocal"]
diff --git a/dateutil/zoneinfo/__init__.py b/dateutil/zoneinfo/__init__.py
index e7709bb..0ffb294 100644
--- a/dateutil/zoneinfo/__init__.py
+++ b/dateutil/zoneinfo/__init__.py
@@ -1,15 +1,16 @@
+# -*- coding: utf-8 -*-
"""
Copyright (c) 2003-2005 Gustavo Niemeyer <gustavo@niemeyer.net>
-This module offers extensions to the standard python 2.3+
+This module offers extensions to the standard Python
datetime module.
"""
from dateutil.tz import tzfile
from tarfile import TarFile
import os
-__author__ = "Gustavo Niemeyer <gustavo@niemeyer.net>"
-__license__ = "PSF License"
+__author__ = "Tomi Pieviläinen <tomi.pievilainen@iki.fi>"
+__license__ = "Simplified BSD"
__all__ = ["setcachesize", "gettz", "rebuild"]
diff --git a/sandbox/scheduler.py b/sandbox/scheduler.py
index 39740eb..62794d5 100644
--- a/sandbox/scheduler.py
+++ b/sandbox/scheduler.py
@@ -1,11 +1,12 @@
+# -*- coding: utf-8 -*-
"""
Copyright (c) 2003-2005 Gustavo Niemeyer <gustavo@niemeyer.net>
-This module offers extensions to the standard python 2.3+
+This module offers extensions to the standard Python
datetime module.
"""
-__author__ = "Gustavo Niemeyer <gustavo@niemeyer.net>"
-__license__ = "PSF License"
+__author__ = "Tomi Pieviläinen <tomi.pievilainen@iki.fi>"
+__license__ = "Simplified BSD"
import datetime
import _thread
diff --git a/setup.py b/setup.py
index 8a6921b..a83903f 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python3
+#!/usr/bin/python
from os.path import isfile, join
import glob
import os
@@ -18,11 +18,11 @@ VERSION = re.search('__version__ = "([^"]+)"',
setup(name="python-dateutil",
version = VERSION,
- description = "Extensions to the standard python 2.3+ datetime module",
- author = "Gustavo Niemeyer",
- author_email = "gustavo@niemeyer.net",
+ description = "Extensions to the standard Python datetime module",
+ author = "Tomi Pievilaeinen",
+ author_email = "tomi.pievilainen@iki.fi",
url = "http://labix.org/python-dateutil",
- license = "PSF License",
+ license = "Simplified BSD",
long_description =
"""\
The dateutil module provides powerful extensions to the
diff --git a/updatezinfo.py b/updatezinfo.py
index ae8b772..415b8c3 100755
--- a/updatezinfo.py
+++ b/updatezinfo.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python3
+#!/usr/bin/python
from dateutil.zoneinfo import rebuild
import shutil
import sys