summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Ganssle <git@m.ganssle.io>2022-12-03 13:04:56 -0500
committerPaul Ganssle <git@m.ganssle.io>2022-12-03 14:16:15 -0500
commit8ecdd44c0f090fb5fd64c90e13044b047597b1ea (patch)
treeb707c04d043f73f222ad2f19e49b202aa2d4d847
parent753660202337c4ea12b52aebeb485c9cf260264a (diff)
downloaddateutil-git-8ecdd44c0f090fb5fd64c90e13044b047597b1ea.tar.gz
Add black and isort configurations
-rw-r--r--pyproject.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e83d69f..67ad619 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -46,3 +46,21 @@ build-backend = "setuptools.build_meta"
name = "Misc"
showcontent = true
+[tool.black]
+line-length = 80
+
+[tool.isort]
+atomic=true
+force_grid_wrap=0
+include_trailing_comma=true
+known_first_party = ["dateutil"]
+known_third_party=[
+ "pytest",
+ "hypothesis",
+ "six",
+ "freezegun",
+ "mock",
+]
+multi_line_output=3
+use_parentheses=true
+