summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Corchero <mcorcherojim@bloomberg.net>2021-07-23 13:59:21 +0200
committerMario Corchero <mcorcherojim@bloomberg.net>2021-07-23 14:04:13 +0200
commit6a79d59935db4ad3dc44306b6747c0a79a2ba0b8 (patch)
treebe3c25807a5de2bbb2079988947a4887e6d6e8fa
parentda9ecd07a257cb5d1c7bfa08459b1ccfcabe6d23 (diff)
downloaddateutil-git-6a79d59935db4ad3dc44306b6747c0a79a2ba0b8.tar.gz
Move tests out of `dateutil` package
Move tests folder to the top of the source checkout and remove it from the package. We are still including the tests in the sdist in case downstream package managers want to test out their packaging.
-rw-r--r--MANIFEST.in2
-rw-r--r--azure-pipelines.yml2
-rwxr-xr-xci_tools/run_tz_master_env.sh2
-rw-r--r--setup.cfg3
-rw-r--r--tests/__init__.py (renamed from src/dateutil/test/__init__.py)0
-rw-r--r--tests/_common.py (renamed from src/dateutil/test/_common.py)0
-rw-r--r--tests/conftest.py (renamed from src/dateutil/test/conftest.py)0
-rw-r--r--tests/property/test_isoparse_prop.py (renamed from src/dateutil/test/property/test_isoparse_prop.py)0
-rw-r--r--tests/property/test_parser_prop.py (renamed from src/dateutil/test/property/test_parser_prop.py)0
-rw-r--r--tests/property/test_tz_prop.py (renamed from src/dateutil/test/property/test_tz_prop.py)0
-rw-r--r--tests/test_easter.py (renamed from src/dateutil/test/test_easter.py)0
-rw-r--r--tests/test_import_star.py (renamed from src/dateutil/test/test_import_star.py)0
-rw-r--r--tests/test_imports.py (renamed from src/dateutil/test/test_imports.py)0
-rw-r--r--tests/test_internals.py (renamed from src/dateutil/test/test_internals.py)0
-rw-r--r--tests/test_isoparser.py (renamed from src/dateutil/test/test_isoparser.py)0
-rw-r--r--tests/test_parser.py (renamed from src/dateutil/test/test_parser.py)0
-rw-r--r--tests/test_relativedelta.py (renamed from src/dateutil/test/test_relativedelta.py)0
-rw-r--r--tests/test_rrule.py (renamed from src/dateutil/test/test_rrule.py)0
-rw-r--r--tests/test_tz.py (renamed from src/dateutil/test/test_tz.py)0
-rw-r--r--tests/test_utils.py (renamed from src/dateutil/test/test_utils.py)0
-rw-r--r--tox.ini4
21 files changed, 5 insertions, 8 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 8e120d9..6690af4 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,4 +1,4 @@
include LICENSE NEWS zonefile_metadata.json updatezinfo.py pyproject.toml
-recursive-include src/dateutil/test *
+recursive-include tests/
global-exclude __pycache__
global-exclude *.py[co]
diff --git a/azure-pipelines.yml b/azure-pipelines.yml
index 096c4ff..e7c7162 100644
--- a/azure-pipelines.yml
+++ b/azure-pipelines.yml
@@ -65,7 +65,7 @@ steps:
- bash: |
if [[ $TOXENV == "py" ]]; then
./ci_tools/retry.sh python updatezinfo.py
- python -m tox -- src/dateutil/test --cov-config=tox.ini --cov=dateutil --junitxml=unittests/TEST-$(Agent.JobName).xml
+ python -m tox -- tests --cov-config=tox.ini --cov=dateutil --junitxml=unittests/TEST-$(Agent.JobName).xml
python -m tox -e coverage,codecov || true
else
python -m tox
diff --git a/ci_tools/run_tz_master_env.sh b/ci_tools/run_tz_master_env.sh
index 373f80e..821a9b0 100755
--- a/ci_tools/run_tz_master_env.sh
+++ b/ci_tools/run_tz_master_env.sh
@@ -93,5 +93,5 @@ ${CITOOLS_DIR}/make_zonefile_metadata.py \
python ${REPO_DIR}/updatezinfo.py $ZONEFILE_METADATA_NAME
# Run the tests
-python -m pytest ${REPO_DIR}/src/dateutil/test $EXTRA_TEST_ARGS
+python -m pytest ${REPO_DIR}/tests $EXTRA_TEST_ARGS
diff --git a/setup.cfg b/setup.cfg
index ed48890..2f02d4e 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -41,11 +41,8 @@ package_dir=
=src
python_requires = >=2.7, !=3.0.*, !=3.1.*, !=3.2.*
packages = find:
-test_suite = dateutil.test
[options.packages.find]
-exclude =
- dateutil.test
where=src
[options.package_data]
diff --git a/src/dateutil/test/__init__.py b/tests/__init__.py
index e69de29..e69de29 100644
--- a/src/dateutil/test/__init__.py
+++ b/tests/__init__.py
diff --git a/src/dateutil/test/_common.py b/tests/_common.py
index b8d2047..b8d2047 100644
--- a/src/dateutil/test/_common.py
+++ b/tests/_common.py
diff --git a/src/dateutil/test/conftest.py b/tests/conftest.py
index 78ed70a..78ed70a 100644
--- a/src/dateutil/test/conftest.py
+++ b/tests/conftest.py
diff --git a/src/dateutil/test/property/test_isoparse_prop.py b/tests/property/test_isoparse_prop.py
index f8e288f..f8e288f 100644
--- a/src/dateutil/test/property/test_isoparse_prop.py
+++ b/tests/property/test_isoparse_prop.py
diff --git a/src/dateutil/test/property/test_parser_prop.py b/tests/property/test_parser_prop.py
index fdfd171..fdfd171 100644
--- a/src/dateutil/test/property/test_parser_prop.py
+++ b/tests/property/test_parser_prop.py
diff --git a/src/dateutil/test/property/test_tz_prop.py b/tests/property/test_tz_prop.py
index ec6d271..ec6d271 100644
--- a/src/dateutil/test/property/test_tz_prop.py
+++ b/tests/property/test_tz_prop.py
diff --git a/src/dateutil/test/test_easter.py b/tests/test_easter.py
index cf2ec7f..cf2ec7f 100644
--- a/src/dateutil/test/test_easter.py
+++ b/tests/test_easter.py
diff --git a/src/dateutil/test/test_import_star.py b/tests/test_import_star.py
index 2fb7098..2fb7098 100644
--- a/src/dateutil/test/test_import_star.py
+++ b/tests/test_import_star.py
diff --git a/src/dateutil/test/test_imports.py b/tests/test_imports.py
index 7d0749e..7d0749e 100644
--- a/src/dateutil/test/test_imports.py
+++ b/tests/test_imports.py
diff --git a/src/dateutil/test/test_internals.py b/tests/test_internals.py
index 5308131..5308131 100644
--- a/src/dateutil/test/test_internals.py
+++ b/tests/test_internals.py
diff --git a/src/dateutil/test/test_isoparser.py b/tests/test_isoparser.py
index 35899ab..35899ab 100644
--- a/src/dateutil/test/test_isoparser.py
+++ b/tests/test_isoparser.py
diff --git a/src/dateutil/test/test_parser.py b/tests/test_parser.py
index 08a34da..08a34da 100644
--- a/src/dateutil/test/test_parser.py
+++ b/tests/test_parser.py
diff --git a/src/dateutil/test/test_relativedelta.py b/tests/test_relativedelta.py
index 1e5d170..1e5d170 100644
--- a/src/dateutil/test/test_relativedelta.py
+++ b/tests/test_relativedelta.py
diff --git a/src/dateutil/test/test_rrule.py b/tests/test_rrule.py
index 52673ec..52673ec 100644
--- a/src/dateutil/test/test_rrule.py
+++ b/tests/test_rrule.py
diff --git a/src/dateutil/test/test_tz.py b/tests/test_tz.py
index e5e4772..e5e4772 100644
--- a/src/dateutil/test/test_tz.py
+++ b/tests/test_tz.py
diff --git a/src/dateutil/test/test_utils.py b/tests/test_utils.py
index fe1bfdc..fe1bfdc 100644
--- a/src/dateutil/test/test_utils.py
+++ b/tests/test_utils.py
diff --git a/tox.ini b/tox.ini
index b2b52b2..ec910f9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -22,14 +22,14 @@ deps =
description = run the unit tests with pytest under {basepython}
setenv = COVERAGE_FILE={toxworkdir}/.coverage.{envname}
passenv = DATEUTIL_MAY_CHANGE_TZ TOXENV CI TRAVIS TRAVIS_* APPVEYOR APPVEYOR_* CODECOV_* SYSTEM_* AGENT_* BUILD_* TF_BUILD
-commands = python -m pytest {posargs: "{toxinidir}/src/dateutil/test" "{toxinidir}/docs" --cov-config="{toxinidir}/tox.ini" --cov=dateutil}
+commands = python -m pytest {posargs: "{toxinidir}/tests" "{toxinidir}/docs" --cov-config="{toxinidir}/tox.ini" --cov=dateutil}
deps = -rrequirements-dev.txt
[testenv:py33]
description = run the unit tests with pytest under Python 3.3
setenv = COVERAGE_FILE={toxworkdir}/.coverage.{envname}
passenv = DATEUTIL_MAY_CHANGE_TZ TOXENV CI TRAVIS TRAVIS_* APPVEYOR APPVEYOR_* CODECOV_* SYSTEM_* AGENT_* BUILD_* TF_BUILD
-commands = python -m pytest {posargs: "{toxinidir}/src/dateutil/test" "{toxinidir}/docs" --cov-config="{toxinidir}/tox.ini" --cov=dateutil}
+commands = python -m pytest {posargs: "{toxinidir}/tests" "{toxinidir}/docs" --cov-config="{toxinidir}/tox.ini" --cov=dateutil}
deps =
-rrequirements/3.3/requirements-dev.txt
-crequirements/3.3/constraints.txt