summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2023-04-25 07:23:57 -0600
committerGitHub <noreply@github.com>2023-04-25 07:23:57 -0600
commitbb91e8b44950e909c6cfa56b9339ccbcc6c66bfe (patch)
tree5a1222edaeb315bf4ad30181b3de585e2d832652 /setup.py
parente03d583dcb29c653074c160169c890ce01400511 (diff)
downloadcryptography-bb91e8b44950e909c6cfa56b9339ccbcc6c66bfe.tar.gz
See if we can always enable abi3 (#8823)
Previously it wasn't because pypy doesn't support abi3, but maybe the pyo3 feature works.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 0 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index b05dc2f12..4fe0c027c 100644
--- a/setup.py
+++ b/setup.py
@@ -54,12 +54,6 @@ try:
"cryptography.hazmat.bindings._rust",
"src/rust/Cargo.toml",
py_limited_api=True,
- # Enable abi3 mode if we're not using PyPy.
- features=(
- []
- if platform.python_implementation() == "PyPy"
- else ["pyo3/abi3-py37"]
- ),
rust_version=">=1.56.0",
)
],