summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>2023-05-07 20:03:37 +0000
committerGitHub <noreply@github.com>2023-05-07 20:03:37 +0000
commite129a1ddbcb359393bb2e45e00d2cfcf64336e39 (patch)
tree62aefd4aaba0e7e42541d070f759fe7e82b96684
parent0f2b72bb12b698e5787241a54ea9132837a1ec9c (diff)
downloadcryptography-e129a1ddbcb359393bb2e45e00d2cfcf64336e39.tar.gz
Bump asn1 from 0.15.1 to 0.15.2 in /src/rust (#8886)
Bumps [asn1](https://github.com/alex/rust-asn1) from 0.15.1 to 0.15.2. - [Commits](https://github.com/alex/rust-asn1/compare/0.15.1...0.15.2) --- updated-dependencies: - dependency-name: asn1 dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com> Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
-rw-r--r--src/rust/Cargo.lock8
-rw-r--r--src/rust/Cargo.toml2
-rw-r--r--src/rust/cryptography-x509/Cargo.toml2
3 files changed, 6 insertions, 6 deletions
diff --git a/src/rust/Cargo.lock b/src/rust/Cargo.lock
index c7e79503c..0c044d097 100644
--- a/src/rust/Cargo.lock
+++ b/src/rust/Cargo.lock
@@ -16,18 +16,18 @@ checksum = "250f629c0161ad8107cf89319e990051fae62832fd343083bea452d93e2205fd"
[[package]]
name = "asn1"
-version = "0.15.1"
+version = "0.15.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "de3ffc84e382cf516922078c67853a781fdb4363cf364594df8eab5ef5485553"
+checksum = "28c19b9324de5b815b6487e0f8098312791b09de0dbf3d5c2db1fe2d95bab973"
dependencies = [
"asn1_derive",
]
[[package]]
name = "asn1_derive"
-version = "0.15.1"
+version = "0.15.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "7124c4d563619518d0ad454032967d5645627033d4b6e4e17bb7ac0237241c81"
+checksum = "a045c3ccad89f244a86bd1e6cf1a7bf645296e7692698b056399b6efd4639407"
dependencies = [
"proc-macro2",
"quote",
diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
index d221cb17a..3efbf1334 100644
--- a/src/rust/Cargo.toml
+++ b/src/rust/Cargo.toml
@@ -10,7 +10,7 @@ rust-version = "1.56.0"
[dependencies]
once_cell = "1"
pyo3 = { version = "0.18", features = ["abi3-py37"] }
-asn1 = { version = "0.15.1", default-features = false }
+asn1 = { version = "0.15.2", default-features = false }
cryptography-cffi = { path = "cryptography-cffi" }
cryptography-x509 = { path = "cryptography-x509" }
cryptography-openssl = { path = "cryptography-openssl" }
diff --git a/src/rust/cryptography-x509/Cargo.toml b/src/rust/cryptography-x509/Cargo.toml
index 8c4d20537..017d51dd4 100644
--- a/src/rust/cryptography-x509/Cargo.toml
+++ b/src/rust/cryptography-x509/Cargo.toml
@@ -8,4 +8,4 @@ publish = false
rust-version = "1.56.0"
[dependencies]
-asn1 = { version = "0.15.1", default-features = false }
+asn1 = { version = "0.15.2", default-features = false }