summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkiorky <kiorky@cryptelium.net>2022-05-14 14:19:35 +0200
committerGitHub <noreply@github.com>2022-05-14 14:19:35 +0200
commit8867d9afcfc2ad79719a4bdc5cfc65b3fe6956d6 (patch)
tree9f7eedd13bf35cf3133873cf08686a39b7e190ba
parentc261113f5e511f080a1939a9cf1672a5980ac7c1 (diff)
parent65056f0dc44d7d3ec59a30952e2f446dc771331e (diff)
downloadcroniter-8867d9afcfc2ad79719a4bdc5cfc65b3fe6956d6.tar.gz
Merge pull request #15 from eelkevdbos/feature/python-310-support
Add Python 3.10 support
-rw-r--r--.github/workflows/cicd.yml4
-rw-r--r--docs/CHANGES.rst1
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
4 files changed, 7 insertions, 5 deletions
diff --git a/.github/workflows/cicd.yml b/.github/workflows/cicd.yml
index 7c82d62..7f5956a 100644
--- a/.github/workflows/cicd.yml
+++ b/.github/workflows/cicd.yml
@@ -5,7 +5,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [2.7, 3.5, 3.6, 3.7, 3.8]
+ python-version: [2.7, 3.5, 3.6, 3.7, 3.8, 3.9, "3.10"]
steps:
- uses: actions/checkout@v2
- name: Set up Python ${{ matrix.python-version }}
@@ -19,7 +19,7 @@ jobs:
pip install -r requirements/test.txt
- name: Test with pytest
run: |
- pyver=$(python --version 2>&1 | awk '{print substr($2, 0, 3)}');
+ pyver=$(python --version 2>&1 | awk '{print substr($2, 0, 4)}' | awk '{ sub(/[ \t]+$/, ""); print }');
case $pyver in
2.7) tox -e "py${pyver//\.}-{std,coverage}";;
*) tox -e "py${pyver//\.}-std";;
diff --git a/docs/CHANGES.rst b/docs/CHANGES.rst
index 0b14e31..1f7ec38 100644
--- a/docs/CHANGES.rst
+++ b/docs/CHANGES.rst
@@ -5,6 +5,7 @@ Changelog
------------------
- Nothing changed yet.
+- Add Python 3.10 support [eelkevdbos]
1.3.4 (2022-02-18)
diff --git a/setup.py b/setup.py
index b8c7e40..c442547 100644
--- a/setup.py
+++ b/setup.py
@@ -54,6 +54,7 @@ setup(
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Topic :: Software Development :: Libraries :: Python Modules"],
packages=find_packages('src', exclude=['tests*', '*.tests*']),
package_dir={'': 'src'},
diff --git a/tox.ini b/tox.ini
index f0a7474..28c9875 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
minversion = 2.3
envlist =
- {py26,py27,py34,py35,py36,py37,py38,py39}-std
+ {py26,py27,py34,py35,py36,py37,py38,py39,py310}-std
py27-coverage
skipsdist = true
@@ -14,8 +14,8 @@ setenv =
COVERAGE_FILE={envdir}/coverage_report
changedir = src
commands =
- {py26,py27,py34,py35,py36,py37,py38,py39}-std: py.test -v .
- {py27,py34,py35,py36,py37,py38,py39}-std: flake8 croniter/croniter.py
+ {py26,py27,py34,py35,py36,py37,py38,py39,py310}-std: py.test -v .
+ {py27,py34,py35,py36,py37,py38,py39,py310}-std: flake8 croniter/croniter.py
py27-coverage: coverage erase
py27-coverage: sh -c 'cd .. && coverage run $(which py.test) -v src'
py27-coverage: coverage report