summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e57a87a..0c92a86 100644
--- a/Makefile
+++ b/Makefile
@@ -28,6 +28,9 @@ install-poetry: ## install or update poetry
install: check-poetry ## install python-creole via poetry
poetry install
+update: check-poetry ## Update the dependencies as according to the pyproject.toml file
+ poetry update
+
lint: ## Run code formatters and linter
poetry run flynt --fail-on-change --line_length=${MAX_LINE_LENGTH} creole
poetry run isort --check-only --recursive creole