summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.creole6
-rw-r--r--README.rst16
-rw-r--r--creole/__init__.py2
-rw-r--r--demo.py3
-rw-r--r--pyproject.toml2
5 files changed, 18 insertions, 11 deletions
diff --git a/README.creole b/README.creole
index 39efa4a..655b821 100644
--- a/README.creole
+++ b/README.creole
@@ -227,10 +227,12 @@ Note: In this case you must install **docutils**! See above.
= history =
-* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.3...master|compare v1.4.3...master]]
+* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.4...master|compare v1.4.4...master]]
+** TBC
+* v1.4.4 - 2020-02-07 - [[https://github.com/jedie/python-creole/compare/v1.4.3...v1.4.4|compare v1.4.3...v1.4.4]]
** Fix #44: Move {{{poetry-publish}}} to {{{dev-dependencies}}} and lower {{{docutils}}} requirement to {{^0.15}}
+** some code style updated
** Always update README.rst before publish
-** TBC
* v1.4.3 - 2020-02-01 - [[https://github.com/jedie/python-creole/compare/v1.4.2...v1.4.3|compare v1.4.2...v1.4.3]]
** Use new [[https://pypi.org/project/poetry-publish/|poetry-publish]] for {{{make publish}}}
* v1.4.2 - 2020-02-01 - [[https://github.com/jedie/python-creole/compare/v1.4.1...v1.4.2|compare v1.4.1...v1.4.2]]
diff --git a/README.rst b/README.rst
index b4529e0..39e180d 100644
--- a/README.rst
+++ b/README.rst
@@ -298,12 +298,18 @@ Note: In this case you must install **docutils**! See above.
history
=======
-* *dev* - `compare v1.4.3...master <https://github.com/jedie/python-creole/compare/v1.4.3...master>`_
-
- * Always update README.rst before publish
+* *dev* - `compare v1.4.4...master <https://github.com/jedie/python-creole/compare/v1.4.4...master>`_
* TBC
+* v1.4.4 - 2020-02-07 - `compare v1.4.3...v1.4.4 <https://github.com/jedie/python-creole/compare/v1.4.3...v1.4.4>`_
+
+ * Fix #44: Move ``poetry-publish`` to ``dev-dependencies`` and lower ``docutils`` requirement to |^0.15|
+
+ * some code style updated
+
+ * Always update README.rst before publish
+
* v1.4.3 - 2020-02-01 - `compare v1.4.2...v1.4.3 <https://github.com/jedie/python-creole/compare/v1.4.2...v1.4.3>`_
* Use new `poetry-publish <https://pypi.org/project/poetry-publish/>`_ for ``make publish``
@@ -628,6 +634,8 @@ history
* first version cut out from `PyLucid CMS <http://www.pylucid.org>`_
+.. |^0.15| image:: ^0.15
+
first source code was written 27.11.2008: `Forum thread (de) <http://www.python-forum.de/viewtopic.php?f=3&t=16742>`_
-------------
@@ -657,4 +665,4 @@ donation
------------
-``Note: this file is generated from README.creole 2020-02-01 22:57:40 with "python-creole"`` \ No newline at end of file
+``Note: this file is generated from README.creole 2020-02-07 15:07:21 with "python-creole"`` \ No newline at end of file
diff --git a/creole/__init__.py b/creole/__init__.py
index d009039..e12ea76 100644
--- a/creole/__init__.py
+++ b/creole/__init__.py
@@ -23,7 +23,7 @@ from creole.parser.creol2html_parser import CreoleParser
from creole.parser.html_parser import HtmlParser
-__version__ = "1.4.3"
+__version__ = "1.4.4"
__api__ = "1.0" # Creole 1.0 spec - http://wikicreole.org/
VERSION_STRING = __version__ # remove in future
diff --git a/demo.py b/demo.py
index 19eae90..93cd349 100644
--- a/demo.py
+++ b/demo.py
@@ -33,17 +33,14 @@ if __name__ == "__main__":
html = creole2html(source_creole)
print(html)
-
print("\n\n" + "_" * 79 + "\n*** Convert html back into creole: ***\n\n")
creole = html2creole(html)
print(creole)
-
print("\n\n" + "_" * 79 + "\n*** Convert html into ReStructuredText: ***\n\n")
rest = html2rest(html)
print(rest)
-
print("\n\n" + "_" * 79 + "\n*** Convert html into textile: ***\n\n")
textile = html2textile(html)
print(textile)
diff --git a/pyproject.toml b/pyproject.toml
index 041d10c..05cc21a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "python-creole"
-version = "1.4.3"
+version = "1.4.4"
description = "python-creole is an open-source (GPL) markup converter in pure Python for: creole2html, html2creole, html2ReSt, html2textile"
# Will be generated from README.creole with: "poetry run update_rst_readme"