summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJens Diemer <github.com@jensdiemer.de>2020-02-01 16:38:48 +0100
committerGitHub <noreply@github.com>2020-02-01 16:38:48 +0100
commit1d2fb1c6ac76674939e6f0c34c8623bb6d22e841 (patch)
tree1bfe84ba3ccb2c6100943e282269a82e36016990 /Makefile
parent69037331053950a1a03324ef3486769cc88ed591 (diff)
parent42af9043fc37dcc81767c2466139b3360d17bc7a (diff)
downloadcreole-1d2fb1c6ac76674939e6f0c34c8623bb6d22e841.tar.gz
Merge pull request #42 from jedie/setup-utils
Setup utils
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/Makefile b/Makefile
index 49576bc..e57a87a 100644
--- a/Makefile
+++ b/Makefile
@@ -56,15 +56,11 @@ tox-py38: check-poetry ## Run pytest via tox with *python v3.8*
pytest: check-poetry ## Run pytest
poetry run pytest
-release: ## Release new version [usage: v=rule]
- # Update pyproject and changelog
- poetry version $(v)
- sed -i "" "s/\[Unreleased\]/\[$(VERSION)\] - $(shell date +%F)/" CHANGELOG.md
- # Create commit and tag
- git commit pyproject.toml CHANGELOG.md -m "Bump version to $(VERSION)" && git tag "v$(VERSION)"
- git push && git push --tags
- # Publish to pypi
- poetry publish --build
-
-
-.PHONY: help install lint fix test release \ No newline at end of file
+update-rst-readme: ## update README.rst from README.creole
+ poetry run update_rst_readme
+
+publish: ## Release new version to PyPi
+ poetry run publish
+
+
+.PHONY: help install lint fix test publish \ No newline at end of file