summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Diemer <github.com@jensdiemer.de>2021-05-11 17:55:00 +0200
committerGitHub <noreply@github.com>2021-05-11 17:55:00 +0200
commite2691629cd8f16f40cf7624e94121441c2c5f526 (patch)
tree7cde3b1c9151d3bb34eaf118897e5b57d0732aae
parentfe2825ab295665e62105d8c950283c15e7fa7af4 (diff)
parent20f3d7089f1557776f3b20a27be5b1ba84595e71 (diff)
downloadcreole-e2691629cd8f16f40cf7624e94121441c2c5f526.tar.gz
Merge pull request #62 from jedie/releasev1.4.10
Release as v1.4.10
-rw-r--r--README.creole8
-rw-r--r--README.rst16
-rw-r--r--creole/__init__.py4
-rw-r--r--pyproject.toml2
4 files changed, 21 insertions, 9 deletions
diff --git a/README.creole b/README.creole
index ebd3ed7..6d48583 100644
--- a/README.creole
+++ b/README.creole
@@ -227,9 +227,13 @@ Note: In this case you must install **docutils**! See above.
= history =
-* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.9...master|compare v1.4.9...master]]
-** Remove Travis CI (All tests already running via github actions)
+* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.10...master|compare v1.4.10...master]]
** TBC
+* v1.4.10 - 2021-05-11 - [[https://github.com/jedie/python-creole/compare/v1.4.9...v1.4.10|compare v1.4.9...v1.4.10]]
+** Update some string formatting to f-strings
+** Replace some {{{join()}}} list comprehension with generators
+** Test on github actions also under MacOS
+** Remove Travis CI (All tests already running via github actions)
* v1.4.9 - 2020-11-4 - [[https://github.com/jedie/python-creole/compare/v1.4.8...v1.4.9|compare v1.4.8...v1.4.9]]
** Add missing classifier for Python 3.9 ([[https://github.com/jedie/python-creole/pull/55|Contributed by jugmac00]])
** Update readme test
diff --git a/README.rst b/README.rst
index 0910aed..34188bd 100644
--- a/README.rst
+++ b/README.rst
@@ -295,12 +295,20 @@ Note: In this case you must install **docutils**! See above.
history
=======
-* *dev* - `compare v1.4.9...master <https://github.com/jedie/python-creole/compare/v1.4.9...master>`_
-
- * Remove Travis CI (All tests already running via github actions)
+* *dev* - `compare v1.4.10...master <https://github.com/jedie/python-creole/compare/v1.4.10...master>`_
* TBC
+* v1.4.10 - 2021-05-11 - `compare v1.4.9...v1.4.10 <https://github.com/jedie/python-creole/compare/v1.4.9...v1.4.10>`_
+
+ * Update some string formatting to f-strings
+
+ * Replace some ``join()`` list comprehension with generators
+
+ * Test on github actions also under MacOS
+
+ * Remove Travis CI (All tests already running via github actions)
+
* v1.4.9 - 2020-11-4 - `compare v1.4.8...v1.4.9 <https://github.com/jedie/python-creole/compare/v1.4.8...v1.4.9>`_
* Add missing classifier for Python 3.9 (`Contributed by jugmac00 <https://github.com/jedie/python-creole/pull/55>`_)
@@ -692,4 +700,4 @@ donation
------------
-``Note: this file is generated from README.creole 2021-05-11 16:05:04 with "python-creole"`` \ No newline at end of file
+``Note: this file is generated from README.creole 2021-05-11 16:58:01 with "python-creole"`` \ No newline at end of file
diff --git a/creole/__init__.py b/creole/__init__.py
index 3f1c443..1ed7752 100644
--- a/creole/__init__.py
+++ b/creole/__init__.py
@@ -8,7 +8,7 @@
:PyPi:
https://pypi.org/project/python-creole/
- :copyleft: 2008-2020 by python-creole team, see AUTHORS for more details.
+ :copyleft: 2008-2021 by python-creole team, see AUTHORS for more details.
:license: GNU GPL v3 or above, see LICENSE for more details.
"""
@@ -23,7 +23,7 @@ from creole.parser.creol2html_parser import CreoleParser
from creole.parser.html_parser import HtmlParser
-__version__ = "1.4.9"
+__version__ = "1.4.10"
__api__ = "1.0" # Creole 1.0 spec - http://wikicreole.org/
VERSION_STRING = __version__ # remove in future
diff --git a/pyproject.toml b/pyproject.toml
index 0dc0a07..3c3135b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "python-creole"
-version = "1.4.9"
+version = "1.4.10"
description = "python-creole is an open-source (GPL) markup converter in pure Python for: creole2html, html2creole, html2ReSt, html2textile"
# Will be generated from README.creole with: "poetry run update_rst_readme"