summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJensDiemer <git@jensdiemer.de>2020-02-01 15:35:15 +0100
committerJensDiemer <git@jensdiemer.de>2020-02-01 15:35:15 +0100
commit93ce69fa86cf908d8a76fe90b4720ea9a27b8dea (patch)
tree3be4dc8c86fc2ed737def3156bb176d4312b6975
parentc2c2b496348a15592242c327ff891383e1d58dee (diff)
downloadcreole-93ce69fa86cf908d8a76fe90b4720ea9a27b8dea.tar.gz
"make release" -> "make publish"
-rw-r--r--Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/Makefile b/Makefile
index 49576bc..3d7a243 100644
--- a/Makefile
+++ b/Makefile
@@ -56,15 +56,9 @@ tox-py38: check-poetry ## Run pytest via tox with *python v3.8*
pytest: check-poetry ## Run pytest
poetry run pytest
-release: ## Release new version [usage: v=rule]
- # Update pyproject and changelog
- poetry version $(v)
- sed -i "" "s/\[Unreleased\]/\[$(VERSION)\] - $(shell date +%F)/" CHANGELOG.md
- # Create commit and tag
- git commit pyproject.toml CHANGELOG.md -m "Bump version to $(VERSION)" && git tag "v$(VERSION)"
- git push && git push --tags
- # Publish to pypi
- poetry publish --build
-
-
-.PHONY: help install lint fix test release \ No newline at end of file
+
+publish: ## Release new version to PyPi
+ poetry run publish
+
+
+.PHONY: help install lint fix test publish \ No newline at end of file