summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJensDiemer <git@jensdiemer.de>2022-08-20 09:53:50 +0200
committerJensDiemer <git@jensdiemer.de>2022-08-20 09:53:50 +0200
commit617e30ad6b99f91950e1939337381af8697222be (patch)
treeb18febc924ff55fb3f1a2a03266fc647d9c20792
parent9dee11204a44b4316ab266d24b467b0a84e89acc (diff)
downloadcreole-617e30ad6b99f91950e1939337381af8697222be.tar.gz
/master/ -> /main/
-rw-r--r--README.creole9
-rw-r--r--README.rst64
2 files changed, 37 insertions, 36 deletions
diff --git a/README.creole b/README.creole
index c40a487..43530f4 100644
--- a/README.creole
+++ b/README.creole
@@ -3,7 +3,7 @@
python-creole is a OpenSource (GPL) Python lib for converting markups.
python-creole is pure python. No external libs needed.
-Compatible Python Versions (see [[https://github.com/jedie/python-creole/blob/master/tox.ini|tox.ini]]):
+Compatible Python Versions (see [[https://github.com/jedie/python-creole/blob/main/tox.ini|tox.ini]]):
* 3.9, 3.8, 3.7, 3.6
* PyPy3
@@ -20,7 +20,7 @@ The creole2html part based on the creole markup parser and emitter from the Moin
| {{https://github.com/jedie/python-creole/workflows/test/badge.svg?branch=master|Build Status on github}} ||
| {{https://coveralls.io/repos/jedie/python-creole/badge.svg|Coverage Status on coveralls.io}} | [[https://coveralls.io/r/jedie/python-creole|coveralls.io/r/jedie/python-creole]] |
-| {{https://landscape.io/github/jedie/python-creole/master/landscape.svg|Status on landscape.io}} | [[https://landscape.io/github/jedie/python-creole/master|landscape.io/github/jedie/python-creole/master]] |
+| {{https://landscape.io/github/jedie/python-creole/main/landscape.svg|Status on landscape.io}} | [[https://landscape.io/github/jedie/python-creole/master|landscape.io/github/jedie/python-creole/master]] |
| {{https://badge.fury.io/py/python-creole.svg|PyPi version}} | [[https://pypi.org/project/python-creole/|pypi.org/project/python-creole/]] |
@@ -91,7 +91,7 @@ Convert html code into textile markup
u'This is *textile __markup__*!'
}}}
-See also: [[http://github.com/jedie/python-creole/blob/master/demo.py]]
+See also: [[http://github.com/jedie/python-creole/blob/main/demo.py]]
= Image size additional =
@@ -112,7 +112,7 @@ The third part ({{{90x160}}}) is not in creole standard, you can force a //stric
= Source code highlighting support =
You can find a example macro which highlight source code thanks to the pygments
-library. It is located here: [[https://github.com/jedie/python-creole/blob/master/creole/shared/example_macros.py|/creole/shared/example_macros.py]].
+library. It is located here: [[https://github.com/jedie/python-creole/blob/main/creole/shared/example_macros.py|/creole/shared/example_macros.py]].
Here is how to use it:
{{{
@@ -229,6 +229,7 @@ Note: In this case you must install **docutils**! See above.
* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.10...master|compare v1.4.10...master]]
** Remove deprecated "parser_kwargs" and "emitter_kwargs"
+** Rename git {{{master}}} branch to {{{main}}}.
** TBC
* v1.4.10 - 2021-05-11 - [[https://github.com/jedie/python-creole/compare/v1.4.9...v1.4.10|compare v1.4.9...v1.4.10]]
** Update some string formatting to f-strings
diff --git a/README.rst b/README.rst
index 23086ef..51e8d0e 100644
--- a/README.rst
+++ b/README.rst
@@ -5,7 +5,7 @@ about python-creole
python-creole is a OpenSource (GPL) Python lib for converting markups.
python-creole is pure python. No external libs needed.
-Compatible Python Versions (see `tox.ini <https://github.com/jedie/python-creole/blob/master/tox.ini>`_):
+Compatible Python Versions (see `tox.ini <https://github.com/jedie/python-creole/blob/main/tox.ini>`_):
* 3.9, 3.8, 3.7, 3.6
@@ -38,7 +38,7 @@ The creole2html part based on the creole markup parser and emitter from the Moin
.. |Build Status on github| image:: https://github.com/jedie/python-creole/workflows/test/badge.svg?branch=master
.. |Coverage Status on coveralls.io| image:: https://coveralls.io/repos/jedie/python-creole/badge.svg
.. _coveralls.io/r/jedie/python-creole: https://coveralls.io/r/jedie/python-creole
-.. |Status on landscape.io| image:: https://landscape.io/github/jedie/python-creole/master/landscape.svg
+.. |Status on landscape.io| image:: https://landscape.io/github/jedie/python-creole/main/landscape.svg
.. _landscape.io/github/jedie/python-creole/master: https://landscape.io/github/jedie/python-creole/master
.. |PyPi version| image:: https://badge.fury.io/py/python-creole.svg
.. _pypi.org/project/python-creole/: https://pypi.org/project/python-creole/
@@ -133,7 +133,7 @@ Convert html code into textile markup
>>> html2textile(u'<p>This is <strong>textile <i>markup</i></strong>!</p>')
u'This is *textile __markup__*!'
-See also: `http://github.com/jedie/python-creole/blob/master/demo.py <http://github.com/jedie/python-creole/blob/master/demo.py>`_
+See also: `http://github.com/jedie/python-creole/blob/main/demo.py <http://github.com/jedie/python-creole/blob/main/demo.py>`_
=====================
Image size additional
@@ -160,7 +160,7 @@ Source code highlighting support
================================
You can find a example macro which highlight source code thanks to the pygments
-library. It is located here: `/creole/shared/example_macros.py <https://github.com/jedie/python-creole/blob/master/creole/shared/example_macros.py>`_.
+library. It is located here: `/creole/shared/example_macros.py <https://github.com/jedie/python-creole/blob/main/creole/shared/example_macros.py>`_.
Here is how to use it:
::
@@ -190,14 +190,14 @@ Here the ``--help`` output from ``html2creole``:
$ html2creole --help
usage: html2creole [-h] [-v] [--encoding ENCODING] sourcefile destination
-
+
python-creole is an open-source (GPL) markup converter in pure Python for:
creole2html, html2creole, html2ReSt, html2textile
-
+
positional arguments:
sourcefile source file to convert
destination Output filename
-
+
optional arguments:
-h, --help show this help message and exit
-v, --version show program's version number and exit
@@ -240,19 +240,19 @@ unittests
# clone repository (or use your fork):
~$ git clone https://github.com/jedie/python-creole.git
~$ cd python-creole
-
+
# install or update poetry:
~/python-creole$ make install-poetry
-
+
# install python-creole via poetry:
~/python-creole$ make install
-
+
# Run pytest:
~/python-creole$ make pytest
-
+
# Run pytest via tox with all environments:
~/python-creole$ make tox
-
+
# Run pytest via tox with one Python version:
~/python-creole$ make tox-py38
~/python-creole$ make tox-py37
@@ -295,13 +295,13 @@ Note: In this case you must install **docutils**! See above.
history
=======
-* *dev* - `compare v1.4.10...master <https://github.com/jedie/python-creole/compare/v1.4.10...master>`_
+* *dev* - `compare v1.4.10...master <https://github.com/jedie/python-creole/compare/v1.4.10...master>`_
* Remove deprecated "parser_kwargs" and "emitter_kwargs"
* TBC
-* v1.4.10 - 2021-05-11 - `compare v1.4.9...v1.4.10 <https://github.com/jedie/python-creole/compare/v1.4.9...v1.4.10>`_
+* v1.4.10 - 2021-05-11 - `compare v1.4.9...v1.4.10 <https://github.com/jedie/python-creole/compare/v1.4.9...v1.4.10>`_
* Update some string formatting to f-strings
@@ -311,17 +311,17 @@ history
* Remove Travis CI (All tests already running via github actions)
-* v1.4.9 - 2020-11-4 - `compare v1.4.8...v1.4.9 <https://github.com/jedie/python-creole/compare/v1.4.8...v1.4.9>`_
+* v1.4.9 - 2020-11-4 - `compare v1.4.8...v1.4.9 <https://github.com/jedie/python-creole/compare/v1.4.8...v1.4.9>`_
* Add missing classifier for Python 3.9 (`Contributed by jugmac00 <https://github.com/jedie/python-creole/pull/55>`_)
* Update readme test
-* v1.4.8 - 2020-10-17 - `compare v1.4.7...v1.4.8 <https://github.com/jedie/python-creole/compare/v1.4.7...v1.4.8>`_
+* v1.4.8 - 2020-10-17 - `compare v1.4.7...v1.4.8 <https://github.com/jedie/python-creole/compare/v1.4.7...v1.4.8>`_
* Validate generated ``README.rst`` with `readme-renderer <https://pypi.org/project/readme-renderer/>`_
-* v1.4.7 - 2020-10-17 - `compare v1.4.6...v1.4.7 <https://github.com/jedie/python-creole/compare/v1.4.6...v1.4.7>`_
+* v1.4.7 - 2020-10-17 - `compare v1.4.6...v1.4.7 <https://github.com/jedie/python-creole/compare/v1.4.6...v1.4.7>`_
* ``update_rst_readme()`` will touch ``README.rst`` if there are not change (timestamp will not changed in file)
@@ -329,17 +329,17 @@ history
* Some meta updates to project setup
-* v1.4.6 - 2020-02-13 - `compare v1.4.5...v1.4.6 <https://github.com/jedie/python-creole/compare/v1.4.5...v1.4.6>`_
+* v1.4.6 - 2020-02-13 - `compare v1.4.5...v1.4.6 <https://github.com/jedie/python-creole/compare/v1.4.5...v1.4.6>`_
* less restricted dependency specification
-* v1.4.5 - 2020-02-13 - `compare v1.4.4...v1.4.5 <https://github.com/jedie/python-creole/compare/v1.4.4...v1.4.5>`_
+* v1.4.5 - 2020-02-13 - `compare v1.4.4...v1.4.5 <https://github.com/jedie/python-creole/compare/v1.4.4...v1.4.5>`_
* new: ``creole.setup_utils.assert_rst_readme`` for project setup tests
* use `https://github.com/ymyzk/tox-gh-actions <https://github.com/ymyzk/tox-gh-actions>`_ on gitlab CI
-* v1.4.4 - 2020-02-07 - `compare v1.4.3...v1.4.4 <https://github.com/jedie/python-creole/compare/v1.4.3...v1.4.4>`_
+* v1.4.4 - 2020-02-07 - `compare v1.4.3...v1.4.4 <https://github.com/jedie/python-creole/compare/v1.4.3...v1.4.4>`_
* Fix #44: Move ``poetry-publish`` to ``dev-dependencies`` and lower ``docutils`` requirement to |^0.15|
@@ -347,11 +347,11 @@ history
* Always update README.rst before publish
-* v1.4.3 - 2020-02-01 - `compare v1.4.2...v1.4.3 <https://github.com/jedie/python-creole/compare/v1.4.2...v1.4.3>`_
+* v1.4.3 - 2020-02-01 - `compare v1.4.2...v1.4.3 <https://github.com/jedie/python-creole/compare/v1.4.2...v1.4.3>`_
* Use new `poetry-publish <https://pypi.org/project/poetry-publish/>`_ for ``make publish``
-* v1.4.2 - 2020-02-01 - `compare v1.4.1...v1.4.2 <https://github.com/jedie/python-creole/compare/v1.4.1...v1.4.2>`_
+* v1.4.2 - 2020-02-01 - `compare v1.4.1...v1.4.2 <https://github.com/jedie/python-creole/compare/v1.4.1...v1.4.2>`_
* Update CI configs on github and travis
@@ -359,7 +359,7 @@ history
* Add generated ``README.rst`` in repository to fix install problems about missing readme
-* v1.4.1 - 2020-01-19 - `compare v1.4.0...v1.4.1 <https://github.com/jedie/python-creole/compare/v1.4.0...v1.4.1>`_
+* v1.4.1 - 2020-01-19 - `compare v1.4.0...v1.4.1 <https://github.com/jedie/python-creole/compare/v1.4.0...v1.4.1>`_
* Remove Python v2 support code
@@ -375,7 +375,7 @@ history
* Activate linting in CI pipeline
-* v1.4.0 - 2020-01-19 - `compare v1.3.2...v1.4.0 <https://github.com/jedie/python-creole/compare/v1.3.2...v1.4.0>`_
+* v1.4.0 - 2020-01-19 - `compare v1.3.2...v1.4.0 <https://github.com/jedie/python-creole/compare/v1.3.2...v1.4.0>`_
* modernize project:
@@ -389,17 +389,17 @@ history
* Test with Python v3.6, v3.7 and v3.8
-* v1.3.2 - 2018-02-27 - `compare v1.3.1...v1.3.2 <https://github.com/jedie/python-creole/compare/v1.3.1...v1.3.2>`_
+* v1.3.2 - 2018-02-27 - `compare v1.3.1...v1.3.2 <https://github.com/jedie/python-creole/compare/v1.3.1...v1.3.2>`_
* Adding optional img size to creole2html and html2creole contributed by `John Dupuy <https://github.com/JohnAD>`_
* run tests also with python 3.5 and 3.6
-* v1.3.1 - 2015-08-15 - `compare v1.3.0...v1.3.1 <https://github.com/jedie/python-creole/compare/v1.3.0...v1.3.1>`_
+* v1.3.1 - 2015-08-15 - `compare v1.3.0...v1.3.1 <https://github.com/jedie/python-creole/compare/v1.3.0...v1.3.1>`_
* Bugfix for "Failed building wheel for python-creole"
-* v1.3.0 - 2015-06-02 - `compare v1.2.2...v1.3.0 <https://github.com/jedie/python-creole/compare/v1.2.2...v1.3.0>`_
+* v1.3.0 - 2015-06-02 - `compare v1.2.2...v1.3.0 <https://github.com/jedie/python-creole/compare/v1.2.2...v1.3.0>`_
* Refactory internal file structure
@@ -413,19 +413,19 @@ history
* use **json.dumps()** instead of **repr()** in some cases
-* v1.2.2 - 2015-04-05 - `compare v1.2.1...v1.2.2 <https://github.com/jedie/python-creole/compare/v1.2.1...v1.2.2>`_
+* v1.2.2 - 2015-04-05 - `compare v1.2.1...v1.2.2 <https://github.com/jedie/python-creole/compare/v1.2.1...v1.2.2>`_
* Bugfix textile unittests if url scheme is unknown
* migrate google-code Wiki to github and remove google-code links
-* v1.2.1 - 2014-09-14 - `compare v1.2.0...v1.2.1 <https://github.com/jedie/python-creole/compare/v1.2.0...v1.2.1>`_
+* v1.2.1 - 2014-09-14 - `compare v1.2.0...v1.2.1 <https://github.com/jedie/python-creole/compare/v1.2.0...v1.2.1>`_
* Use origin PyPi code to check generated reStructuredText in setup.py
* Update unitest for textile v2.1.8
-* v1.2.0 - 2014-05-15 - `compare v1.1.1...v1.2.0 <https://github.com/jedie/python-creole/compare/v1.1.1...v1.2.0>`_
+* v1.2.0 - 2014-05-15 - `compare v1.1.1...v1.2.0 <https://github.com/jedie/python-creole/compare/v1.1.1...v1.2.0>`_
* NEW: Add ``<<code>>`` example macro (Source code highlighting with pygments) - implemented by Julien Enselme
@@ -555,7 +555,7 @@ history
* Bugfix if docutils are not installed
- * API change: rest2html is now here: ``from creole.rest2html.clean_writer import rest2html``
+ * API change: rest2html is now here: ``from creole.rest2html.clean_writer import rest2html``
* v0.7.0
@@ -702,4 +702,4 @@ donation
------------
-``Note: this file is generated from README.creole 2021-12-05 16:58:04 with "python-creole"`` \ No newline at end of file
+``Note: this file is generated from README.creole 2021-12-05 16:58:04 with "python-creole"``