summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJensDiemer <git@jensdiemer.de>2020-10-17 21:08:44 +0200
committerJensDiemer <git@jensdiemer.de>2020-10-17 21:08:56 +0200
commit55b4ce7e1a789ba90b3cd8c7c30e0217a9e93508 (patch)
tree5b6150c4e04e1bdf726315e20f4062f56d1a3dea
parenta2806596d1e5862e0b306e5268451bc7d3d90646 (diff)
downloadcreole-55b4ce7e1a789ba90b3cd8c7c30e0217a9e93508.tar.gz
release as v1.4.7v1.4.7
-rw-r--r--README.creole5
-rw-r--r--README.rst10
-rw-r--r--creole/__init__.py2
-rw-r--r--pyproject.toml2
4 files changed, 11 insertions, 8 deletions
diff --git a/README.creole b/README.creole
index 8317539..af4d84f 100644
--- a/README.creole
+++ b/README.creole
@@ -227,11 +227,12 @@ Note: In this case you must install **docutils**! See above.
= history =
-* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.6...master|compare v1.4.6...master]]
+* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.7...master|compare v1.4.7...master]]
+** TBC
+* v1.4.7 - 2020-10-17 - [[https://github.com/jedie/python-creole/compare/v1.4.6...v1.4.7|compare v1.4.6...v1.4.7]]
** {{{update_rst_readme()}}} will touch {{{README.rst}}} if there are not change (timestamp will not changed in file)
** Run tests with Python 3.9, too.
** Some meta updates to project setup
-** TBC
* v1.4.6 - 2020-02-13 - [[https://github.com/jedie/python-creole/compare/v1.4.5...v1.4.6|compare v1.4.5...v1.4.6]]
** less restricted dependency specification
* v1.4.5 - 2020-02-13 - [[https://github.com/jedie/python-creole/compare/v1.4.4...v1.4.5|compare v1.4.4...v1.4.5]]
diff --git a/README.rst b/README.rst
index 6c01bf2..81ee62b 100644
--- a/README.rst
+++ b/README.rst
@@ -298,7 +298,11 @@ Note: In this case you must install **docutils**! See above.
history
=======
-* *dev* - `compare v1.4.6...master <https://github.com/jedie/python-creole/compare/v1.4.6...master>`_
+* *dev* - `compare v1.4.7...master <https://github.com/jedie/python-creole/compare/v1.4.7...master>`_
+
+ * TBC
+
+* v1.4.7 - 2020-10-17 - `compare v1.4.6...v1.4.7 <https://github.com/jedie/python-creole/compare/v1.4.6...v1.4.7>`_
* ``update_rst_readme()`` will touch ``README.rst`` if there are not change (timestamp will not changed in file)
@@ -306,8 +310,6 @@ history
* Some meta updates to project setup
- * TBC
-
* v1.4.6 - 2020-02-13 - `compare v1.4.5...v1.4.6 <https://github.com/jedie/python-creole/compare/v1.4.5...v1.4.6>`_
* less restricted dependency specification
@@ -681,4 +683,4 @@ donation
------------
-``Note: this file is generated from README.creole 2020-10-17 21:03:50 with "python-creole"`` \ No newline at end of file
+``Note: this file is generated from README.creole 2020-10-17 21:06:26 with "python-creole"`` \ No newline at end of file
diff --git a/creole/__init__.py b/creole/__init__.py
index 3ff8bf0..c9385af 100644
--- a/creole/__init__.py
+++ b/creole/__init__.py
@@ -23,7 +23,7 @@ from creole.parser.creol2html_parser import CreoleParser
from creole.parser.html_parser import HtmlParser
-__version__ = "1.4.6"
+__version__ = "1.4.7"
__api__ = "1.0" # Creole 1.0 spec - http://wikicreole.org/
VERSION_STRING = __version__ # remove in future
diff --git a/pyproject.toml b/pyproject.toml
index fce9de7..d014cfb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "python-creole"
-version = "1.4.6"
+version = "1.4.7"
description = "python-creole is an open-source (GPL) markup converter in pure Python for: creole2html, html2creole, html2ReSt, html2textile"
# Will be generated from README.creole with: "poetry run update_rst_readme"