summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Diemer <github.com@jensdiemer.de>2020-02-01 22:33:16 +0100
committerGitHub <noreply@github.com>2020-02-01 22:33:16 +0100
commit3cbcdc3010e5bc396199e1c8124627eaafdf468a (patch)
treee1fff1a268c164a23a622d1dffb80f0a4f087464
parent8b51c942be0f17bdeacd1d7ebd74d2c19ed74f29 (diff)
downloadcreole-3cbcdc3010e5bc396199e1c8124627eaafdf468a.tar.gz
Update pyproject.toml
use the default code style from poetry
-rw-r--r--pyproject.toml91
1 files changed, 46 insertions, 45 deletions
diff --git a/pyproject.toml b/pyproject.toml
index cc706a4..c3f1800 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,62 +1,63 @@
[tool.poetry]
-name = 'python-creole'
-version = '1.4.2'
-description = 'python-creole is an open-source (GPL) markup converter in pure Python for: creole2html, html2creole, html2ReSt, html2textile'
+name = "python-creole"
+version = "1.4.2"
+description = "python-creole is an open-source (GPL) markup converter in pure Python for: creole2html, html2creole, html2ReSt, html2textile"
-# Will be generated from README.creole with: 'poetry run update_rst_readme'
-readme='README.rst'
+# Will be generated from README.creole with: "poetry run update_rst_readme"
+readme="README.rst"
-license = 'GPL-3.0-or-later'
-authors = ['Jens Diemer <python-creole@jensdiemer.de>']
-homepage = 'https://github.com/jedie/python-creole/'
-keywords=['creole', 'markup', 'creole2html', 'html2creole', 'rest2html', 'html2rest', 'html2textile']
+license = "GPL-3.0-or-later"
+authors = ["Jens Diemer <python-creole@jensdiemer.de>"]
+homepage = "https://github.com/jedie/python-creole/"
+keywords=["creole", "markup", "creole2html", "html2creole", "rest2html", "html2rest", "html2textile"]
classifiers = [
# http://pypi.python.org/pypi?%3Aaction=list_classifiers
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU General Public License (GPL)',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Operating System :: OS Independent',
- 'Topic :: Documentation',
- 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Topic :: Text Processing :: Markup',
- 'Topic :: Text Processing :: Markup :: HTML',
- 'Topic :: Utilities',
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: GNU General Public License (GPL)",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Operating System :: OS Independent",
+ "Topic :: Documentation",
+ "Topic :: Internet :: WWW/HTTP :: Dynamic Content",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Text Processing :: Markup",
+ "Topic :: Text Processing :: Markup :: HTML",
+ "Topic :: Utilities",
]
packages = [
- { include = 'creole' },
+ { include = "creole" },
]
[tool.poetry.dependencies]
-python = '^3.6'
-docutils = '^0.16'
+python = "^3.6"
+docutils = "^0.16"
+poetry-publish = "^0.2.2"
[tool.poetry.dev-dependencies]
-tox = '^3.14.3'
-pygments = '^2.5.2'
-textile = '^4.0.0'
-pytest = '^4.6'
-pytest-cov = '^2.8.1'
-isort = '^4.3.21'
-flake8 = '^3.7.9'
-flynt = '^0.40.1'
-autopep8 = '^1.4.4'
+tox = "^3.14.3"
+pygments = "^2.5.2"
+textile = "^4.0.0"
+pytest = "^4.6"
+pytest-cov = "^2.8.1"
+isort = "^4.3.21"
+flake8 = "^3.7.9"
+flynt = "^0.40.1"
+autopep8 = "^1.4.4"
[tool.poetry.scripts]
-creole2html = 'creole.cmdline:cli_creole2html'
-html2creole = 'creole.cmdline:cli_html2creole'
-html2rest = 'creole.cmdline:cli_html2rest'
-html2textile = 'creole.cmdline:cli_html2textile'
-update_rst_readme = 'creole.setup_utils:update_creole_rst_readme'
-publish = 'creole.setup_utils:publish_python_creole'
+creole2html = "creole.cmdline:cli_creole2html"
+html2creole = "creole.cmdline:cli_html2creole"
+html2rest = "creole.cmdline:cli_html2rest"
+html2textile = "creole.cmdline:cli_html2textile"
+update_rst_readme = "creole.setup_utils:update_creole_rst_readme"
+publish = "creole.publish:publish"
[build-system]
-requires = ['poetry>=0.12']
-build-backend = 'poetry.masonry.api'
+requires = ["poetry>=0.12"]
+build-backend = "poetry.masonry.api"