summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Diemer <github.com@jensdiemer.de>2020-11-04 08:49:15 +0100
committerGitHub <noreply@github.com>2020-11-04 08:49:15 +0100
commit38958d3f317f4d3140c38d217d140ed6eee40600 (patch)
treed4c9d34abb9c2dfa07a9e29e0c3e2a977e641711
parent808dbc0552a38b15f3f31e1ca611e7b31b7870ac (diff)
parentb622957a8747716db66d57dcde1288e0898b72f2 (diff)
downloadcreole-38958d3f317f4d3140c38d217d140ed6eee40600.tar.gz
Merge pull request #56 from jedie/releasev1.4.9
Release
-rw-r--r--AUTHORS3
-rw-r--r--Makefile3
-rw-r--r--README.creole6
-rw-r--r--README.rst11
-rw-r--r--creole/__init__.py2
-rw-r--r--creole/tests/test_project_setup.py18
-rw-r--r--pyproject.toml2
7 files changed, 32 insertions, 13 deletions
diff --git a/AUTHORS b/AUTHORS
index 5f8b042..82b74d8 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -16,11 +16,12 @@ PRIMARY AUTHORS are and/or have been (alphabetic order):
CONTRIBUTORS are and/or have been:
+* Jürgen Gmach <https://github.com/jugmac00>
* John Dupuy <https://github.com/JohnAD>
* Julien Enselme <https://github.com/Jenselme>
* Sepero <https://github.com/Sepero>
* Vitja.Makarov <http://code.google.com/u/Vitja.Makarov/>
-* Betz Stefan alias 'encbladexp' <http://www.stefan-betz.net/>
+* Betz Stefan alias 'encbladexp' <http://www.stefan-betz.net/>
* Eric O'Connell <eric@zerominuszero.net>
diff --git a/Makefile b/Makefile
index 76eb81f..1e23439 100644
--- a/Makefile
+++ b/Makefile
@@ -57,6 +57,9 @@ tox-py37: check-poetry ## Run pytest via tox with *python v3.7*
tox-py38: check-poetry ## Run pytest via tox with *python v3.8*
poetry run tox -e py38
+tox-py39: check-poetry ## Run pytest via tox with *python v3.9*
+ poetry run tox -e py39
+
pytest: check-poetry ## Run pytest
poetry run pytest
diff --git a/README.creole b/README.creole
index 7f6b6ac..bc9137b 100644
--- a/README.creole
+++ b/README.creole
@@ -212,6 +212,7 @@ tox Run pytest via tox with all environments
tox-py36 Run pytest via tox with *python v3.6*
tox-py37 Run pytest via tox with *python v3.7*
tox-py38 Run pytest via tox with *python v3.8*
+tox-py39 Run pytest via tox with *python v3.9*
pytest Run pytest
update-rst-readme update README.rst from README.creole
publish Release new version to PyPi
@@ -227,8 +228,11 @@ Note: In this case you must install **docutils**! See above.
= history =
-* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.7...master|compare v1.4.7...master]]
+* *dev* - [[https://github.com/jedie/python-creole/compare/v1.4.9...master|compare v1.4.9...master]]
** TBC
+* v1.4.9 - 2020-11-4 - [[https://github.com/jedie/python-creole/compare/v1.4.8...v1.4.9|compare v1.4.8...v1.4.9]]
+** Add missing classifier for Python 3.9 ([[https://github.com/jedie/python-creole/pull/55|Contributed by jugmac00]])
+** Update readme test
* v1.4.8 - 2020-10-17 - [[https://github.com/jedie/python-creole/compare/v1.4.7...v1.4.8|compare v1.4.7...v1.4.8]]
** Validate generated {{{README.rst}}} with [[https://pypi.org/project/readme-renderer/|readme-renderer]]
* v1.4.7 - 2020-10-17 - [[https://github.com/jedie/python-creole/compare/v1.4.6...v1.4.7|compare v1.4.6...v1.4.7]]
diff --git a/README.rst b/README.rst
index 2dcaf62..f5c0826 100644
--- a/README.rst
+++ b/README.rst
@@ -281,6 +281,7 @@ To see all make targets, just call ``make``:
tox-py36 Run pytest via tox with *python v3.6*
tox-py37 Run pytest via tox with *python v3.7*
tox-py38 Run pytest via tox with *python v3.8*
+ tox-py39 Run pytest via tox with *python v3.9*
pytest Run pytest
update-rst-readme update README.rst from README.creole
publish Release new version to PyPi
@@ -298,10 +299,16 @@ Note: In this case you must install **docutils**! See above.
history
=======
-* *dev* - `compare v1.4.7...master <https://github.com/jedie/python-creole/compare/v1.4.7...master>`_
+* *dev* - `compare v1.4.9...master <https://github.com/jedie/python-creole/compare/v1.4.9...master>`_
* TBC
+* v1.4.9 - 2020-11-4 - `compare v1.4.8...v1.4.9 <https://github.com/jedie/python-creole/compare/v1.4.8...v1.4.9>`_
+
+ * Add missing classifier for Python 3.9 (`Contributed by jugmac00 <https://github.com/jedie/python-creole/pull/55>`_)
+
+ * Update readme test
+
* v1.4.8 - 2020-10-17 - `compare v1.4.7...v1.4.8 <https://github.com/jedie/python-creole/compare/v1.4.7...v1.4.8>`_
* Validate generated ``README.rst`` with `readme-renderer <https://pypi.org/project/readme-renderer/>`_
@@ -687,4 +694,4 @@ donation
------------
-``Note: this file is generated from README.creole 2020-10-17 22:52:28 with "python-creole"`` \ No newline at end of file
+``Note: this file is generated from README.creole 2020-11-04 08:46:39 with "python-creole"`` \ No newline at end of file
diff --git a/creole/__init__.py b/creole/__init__.py
index 6acb5b9..3f1c443 100644
--- a/creole/__init__.py
+++ b/creole/__init__.py
@@ -23,7 +23,7 @@ from creole.parser.creol2html_parser import CreoleParser
from creole.parser.html_parser import HtmlParser
-__version__ = "1.4.8"
+__version__ = "1.4.9"
__api__ = "1.0" # Creole 1.0 spec - http://wikicreole.org/
VERSION_STRING = __version__ # remove in future
diff --git a/creole/tests/test_project_setup.py b/creole/tests/test_project_setup.py
index cc06578..cb9aa1e 100644
--- a/creole/tests/test_project_setup.py
+++ b/creole/tests/test_project_setup.py
@@ -2,11 +2,13 @@
:copyleft: 2020 by python-creole team, see AUTHORS for more details.
:license: GNU GPL v3 or above, see LICENSE for more details.
"""
-from poetry_publish.tests.test_assert_rst_readme import test_assert_rst_readme as assert_rst_readme
+from pathlib import Path
+
from poetry_publish.tests.test_project_setup import test_poetry_check as assert_poetry_check
from poetry_publish.tests.test_project_setup import test_version as assert_version
from creole import __version__
+from creole.setup_utils import update_rst_readme
from creole.tests.constants import CREOLE_PACKAGE_ROOT
@@ -18,13 +20,15 @@ def test_version():
assert_version(package_root=CREOLE_PACKAGE_ROOT, version=__version__)
-def test_assert_rst_readme():
- """
- Check if own README.rst is up-to-date with README.creole
- """
- assert_rst_readme(
- package_root=CREOLE_PACKAGE_ROOT, version=__version__, filename='README.creole'
+def test_update_rst_readme(capsys):
+ rest_readme_path = update_rst_readme(
+ package_root=CREOLE_PACKAGE_ROOT, filename='README.creole'
)
+ captured = capsys.readouterr()
+ assert captured.out == 'Generate README.rst from README.creole...nothing changed, ok.\n'
+ assert captured.err == ''
+ assert isinstance(rest_readme_path, Path)
+ assert str(rest_readme_path).endswith('/README.rst')
def test_poetry_check():
diff --git a/pyproject.toml b/pyproject.toml
index e9f5fdc..0dc0a07 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "python-creole"
-version = "1.4.8"
+version = "1.4.9"
description = "python-creole is an open-source (GPL) markup converter in pure Python for: creole2html, html2creole, html2ReSt, html2textile"
# Will be generated from README.creole with: "poetry run update_rst_readme"