summaryrefslogtreecommitdiff
path: root/rpm
diff options
context:
space:
mode:
authorJerome Martin <jxm@risingtidesystems.com>2011-10-18 22:21:04 +0200
committerJerome Martin <jxm@risingtidesystems.com>2011-10-19 00:08:19 +0200
commite2c5e356cb0c8c9e9089795b1a04a7927e9f8ad8 (patch)
tree2da738cf68ca248cb13e1c4ff69358b91c2d190e /rpm
parent9e7959d4f4f32178ca1dcff862a56171c45c199b (diff)
downloadconfigshell-fb-e2c5e356cb0c8c9e9089795b1a04a7927e9f8ad8.tar.gz
Cleaned up packaging
* Merged doc with main package. * Not generating pdf anymore, HTML doc is better and cross-referenced anyway and the PDF generation was too dependent on LaTeX distributions which caused endless issues on several systems. * Renamed redhat/ into rpm/, as we also try to aim for SuSe compat, so the old name wasn't making sense anymore. * Added install prefix explicitely to specfile, needed on OpenSuSe, whose default is /usr/local instead of /usr
Diffstat (limited to 'rpm')
-rw-r--r--rpm/python-configshell.spec.tmpl46
1 files changed, 46 insertions, 0 deletions
diff --git a/rpm/python-configshell.spec.tmpl b/rpm/python-configshell.spec.tmpl
new file mode 100644
index 0000000..71b4c1c
--- /dev/null
+++ b/rpm/python-configshell.spec.tmpl
@@ -0,0 +1,46 @@
+%define oname configshell
+
+Name: python-configshell
+License: AGPLv3
+Group: System Environment/Libraries
+Summary: A framework to implement simple but nice CLIs.
+Version: VERSION
+Release: 1%{?dist}
+URL: http://www.risingtidesystems.com/git/
+Source: %{oname}-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-rpmroot
+BuildArch: noarch
+BuildRequires: python-devel, epydoc, python-simpleparse
+Requires: python-simpleparse, python-urwid >= 0.9.9, epydoc
+Vendor: RisingTide Systems
+
+%description
+A framework to implement simple but nice command-line interfaces.
+
+%prep
+%setup -q -n %{oname}-%{version}
+
+%build
+%{__python} setup.py build
+mkdir -p doc/
+epydoc --no-sourcecode --html -n %{oname} --exclude configobj %{oname}/*.py
+sed -i "s/<\?/<!/g" html/*.html
+sed -i "s/\?>/>/g" html/*.html
+mv html doc/
+
+%install
+rm -rf %{buildroot}
+%{__python} setup.py install --skip-build --root %{buildroot} --prefix=usr
+mkdir -p %{buildroot}/usr/share/doc/python-configshell-doc-%{version}
+cp -r doc/* %{buildroot}/usr/share/doc/python-configshell-doc-%{version}/
+
+%clean
+rm -rf %{buildroot}
+
+%files
+%defattr(-,root,root,-)
+%{python_sitelib}
+/usr/share/doc/python-configshell-doc-%{version}
+%doc examples COPYING README
+
+%changelog