summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorNicholas Bellinger <nab@risingtidesystems.com>2011-05-04 20:47:59 +0000
committerNicholas Bellinger <nab@risingtidesystems.com>2011-05-04 20:47:59 +0000
commitce5bb566c2f3332911e986fada91836d2ef09479 (patch)
tree808b495f51fad553cac0b51fc4d83cefff452fcb /debian
downloadconfigshell-fb-ce5bb566c2f3332911e986fada91836d2ef09479.tar.gz
Initial configshell commit0.9
Signed-off-by: Nicholas A. Bellinger <nab@risingtidesystems.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian13
-rw-r--r--debian/compat1
-rw-r--r--debian/configshell-doc.docs5
-rw-r--r--debian/control24
-rw-r--r--debian/copyright13
-rw-r--r--debian/python-configshell.dirs1
-rw-r--r--debian/python-configshell.docs3
-rw-r--r--debian/python-configshell.install1
-rwxr-xr-xdebian/python-configshell.postinst17
-rwxr-xr-xdebian/python-configshell.preinst3
-rwxr-xr-xdebian/python-configshell.prerm8
-rw-r--r--debian/pyversions1
-rwxr-xr-xdebian/rules48
13 files changed, 138 insertions, 0 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..374bba0
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,13 @@
+Copyright (c) 2011 by RisingTide Systems LLC
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU Affero General Public License as
+published by the Free Software Foundation, version 3 (AGPLv3).
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU Affero General Public License for more details.
+
+You should have received a copy of the GNU Affero General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/configshell-doc.docs b/debian/configshell-doc.docs
new file mode 100644
index 0000000..37ad01a
--- /dev/null
+++ b/debian/configshell-doc.docs
@@ -0,0 +1,5 @@
+README
+COPYING
+doc/pdf
+doc/html
+examples/myshell
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..69f19bc
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,24 @@
+Source: configshell
+Section: python
+Priority: optional
+Maintainer: Jerome Martin <jxm@risingtidesystems.com>
+Build-Depends: debhelper(>= 7.0.1), python2.6, python-epydoc, python-simpleparse
+Standards-Version: 3.8.1
+
+Package: python-configshell
+Architecture: all
+Depends: python (>= 2.6)|python2.6, python-epydoc, python-simpleparse, python-urwid
+Suggests: configshell-doc
+Description: Framework to create CLI interfaces.
+ .
+ This package contains the configshell library.
+
+Package: configshell-doc
+Section: doc
+Architecture: all
+Recommends: iceweasel | www-browser
+Description: official API documentation for the configshell library
+ .
+ This package contains the API reference and usage information for configshell,
+ a framework to create CLI interfaces.
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..80d4fbd
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,13 @@
+This package was originally debianized by Jerome Martin <jxm@risingtidesystems.com>
+on Thu Sep 09 23:13:01 CET 2010. It is currently maintained by Jerome Martin
+<jxm@risingtidesystems.com>.
+
+Upstream Author: Jerome Martin <jxm@risingtidesystems.com>
+
+Copyright:
+
+ Copyright (c) 2010 by RisingTide Systems LLC.
+ All rights reserved.
+ For licensing information, please contact us.
+ Not for redistribution.
+
diff --git a/debian/python-configshell.dirs b/debian/python-configshell.dirs
new file mode 100644
index 0000000..145429c
--- /dev/null
+++ b/debian/python-configshell.dirs
@@ -0,0 +1 @@
+usr/share/python-support
diff --git a/debian/python-configshell.docs b/debian/python-configshell.docs
new file mode 100644
index 0000000..8b39665
--- /dev/null
+++ b/debian/python-configshell.docs
@@ -0,0 +1,3 @@
+README
+COPYING
+examples/myshell
diff --git a/debian/python-configshell.install b/debian/python-configshell.install
new file mode 100644
index 0000000..69bb674
--- /dev/null
+++ b/debian/python-configshell.install
@@ -0,0 +1 @@
+lib/configshell usr/share/python-support
diff --git a/debian/python-configshell.postinst b/debian/python-configshell.postinst
new file mode 100755
index 0000000..b56990a
--- /dev/null
+++ b/debian/python-configshell.postinst
@@ -0,0 +1,17 @@
+#!/bin/sh
+for lib in lib lib64; do
+ for python in python2.6; do
+ if [ -e /usr/${lib}/${python} ]; then
+ if [ ! -e /usr/${lib}/${python}/configshell ]; then
+ mkdir /usr/${lib}/${python}/configshell
+ for source in /usr/share/python-support/configshell/configshell/*.py; do
+ ln -sf ${source} /usr/${lib}/${python}/configshell/
+ done
+ python_path=$(which ${python} 2>/dev/null)
+ if [ ! -z $python_path ]; then
+ ${python} -c "import compileall; compileall.compile_dir('/usr/${lib}/${python}/configshell', force=1)"
+ fi
+ fi
+ fi
+ done
+done
diff --git a/debian/python-configshell.preinst b/debian/python-configshell.preinst
new file mode 100755
index 0000000..b96bf44
--- /dev/null
+++ b/debian/python-configshell.preinst
@@ -0,0 +1,3 @@
+#!/bin/sh
+rm -f /usr/share/python-support/configshell/configshell/*.pyc
+rm -f /usr/share/python-support/configshell/configshell/*.pyo
diff --git a/debian/python-configshell.prerm b/debian/python-configshell.prerm
new file mode 100755
index 0000000..866a5c2
--- /dev/null
+++ b/debian/python-configshell.prerm
@@ -0,0 +1,8 @@
+#!/bin/sh
+for lib in lib lib64; do
+ for python in python2.6; do
+ if [ -e /usr/${lib}/${python}/configshell ]; then
+ rm -rf /usr/${lib}/${python}/configshell
+ fi
+ done
+done
diff --git a/debian/pyversions b/debian/pyversions
new file mode 100644
index 0000000..0c043f1
--- /dev/null
+++ b/debian/pyversions
@@ -0,0 +1 @@
+2.6-
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d8cd635
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,48 @@
+#!/usr/bin/make -f
+
+build_dir = build
+install_dir = debian/tmp
+setup = /usr/bin/python ./setup.py --quiet
+
+binary: binary-indep
+
+binary-arch:
+
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installman
+ dh_install --list-missing --sourcedir $(install_dir)
+ dh_fixperms
+ dh_compress -X.py
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_installdirs
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ $(setup) build --build-base $(build_dir) install --no-compile --install-purelib $(install_dir)/lib/configshell --install-scripts $(install_dir)/bin
+ echo "2.6" > $(install_dir)/lib/configshell/.version
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+ $(setup) clean
+ find . -name "*.pyc" | xargs rm -f
+ find . -name "*.pyo" | xargs rm -f
+ rm -rf $(build_dir) $(install_dir)
+ dh_clean
+
+.PHONY: binary binary-indep install build clean
+