summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Vu-Brugier <cvubrugier@fastmail.fm>2016-10-21 11:08:28 +0200
committerChristophe Vu-Brugier <cvubrugier@fastmail.fm>2016-10-24 20:19:49 +0200
commitf2758a19c522b086ee51597266626f35ebc555fc (patch)
tree95a14d34ebc9e305d7f3d252d0061da728488090
parent8feb09b67f6e87ee4920216ab8e647f8758d689e (diff)
downloadconfigshell-fb-f2758a19c522b086ee51597266626f35ebc555fc.tar.gz
Remove build scripts for RPM and Debian packages
Remove the "debian" directory because Debian packagers have reported in the past that having a "debian" directory makes their work harder when merging the upstream branch into their packaging branch. Moreover, our in-repo Debian packaging is less complete than the Debian packaging. Also remove our in-repo RPM packaging which is probably lagging behind Fedora's packaging. Finally, this patch adds a few links to RPM and Debian build scripts in our README.md. Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm>
-rw-r--r--Makefile69
-rw-r--r--README.md16
-rw-r--r--debian/README.Debian13
-rw-r--r--debian/compat1
-rw-r--r--debian/control32
-rw-r--r--debian/copyright21
-rw-r--r--debian/python-configshell-fb-docs.doc-base9
-rw-r--r--debian/python-configshell-fb.install1
-rw-r--r--debian/python3-configshell-fb.install1
-rwxr-xr-xdebian/rules46
-rw-r--r--debian/source/format1
-rw-r--r--rpm/python-configshell.spec.tmpl44
12 files changed, 7 insertions, 247 deletions
diff --git a/Makefile b/Makefile
index cda0e5e..a91fdc8 100644
--- a/Makefile
+++ b/Makefile
@@ -6,8 +6,6 @@ VERSION = $$(basename $$(git describe --tags | tr - . | sed 's/^v//'))
all:
@echo "Usage:"
@echo
- @echo " make deb - Builds debian packages."
- @echo " make rpm - Builds rpm packages."
@echo " make release - Generates the release tarball."
@echo
@echo " make clean - Cleanup the local repository build files."
@@ -17,15 +15,7 @@ clean:
@rm -fv ${NAME}/*.pyc ${NAME}/*.html
@rm -frv doc
@rm -frv ${NAME}.egg-info MANIFEST build
- @rm -frv debian/tmp
- @rm -fv build-stamp
- @rm -fv dpkg-buildpackage.log dpkg-buildpackage.version
- @rm -frv *.rpm
- @rm -fv debian/files debian/*.log debian/*.substvars
- @rm -frv debian/${PKGNAME}-doc/ debian/python2.5-${PKGNAME}/
- @rm -frv debian/python2.6-${PKGNAME}/ debian/python-${PKGNAME}/
@rm -frv results
- @rm -fv rpm/*.spec *.spec rpm/sed* sed*
@rm -frv ${PKGNAME}-*
@echo "Finished cleanup."
@@ -44,41 +34,6 @@ build/release-stamp:
@echo "Fixing version string..."
@sed -i "s/__version__ = .*/__version__ = '${VERSION}'/g" \
build/${PKGNAME}-${VERSION}/${NAME}/__init__.py
- @echo "Generating rpm specfile from template..."
- @cd build/${PKGNAME}-${VERSION}; \
- for spectmpl in rpm/*.spec.tmpl; do \
- sed -i "s/Version:\( *\).*/Version:\1${VERSION}/g" $${spectmpl}; \
- mv $${spectmpl} $$(basename $${spectmpl} .tmpl); \
- done; \
- rm -r rpm
- @echo "Generating rpm changelog..."
- @( \
- version=${VERSION}; \
- author=$$(git show HEAD --format="format:%an <%ae>" -s); \
- date=$$(git show HEAD --format="format:%ad" -s \
- | awk '{print $$1,$$2,$$3,$$5}'); \
- hash=$$(git show HEAD --format="format:%H" -s); \
- echo '* '"$${date} $${author} $${version}-1"; \
- echo " - Generated from git commit $${hash}."; \
- ) >> $$(ls build/${PKGNAME}-${VERSION}/*.spec)
- @echo "Generating debian changelog..."
- @( \
- version=${VERSION}; \
- author=$$(git show HEAD --format="format:%an <%ae>" -s); \
- date=$$(git show HEAD --format="format:%aD" -s); \
- day=$$(git show HEAD --format='format:%ai' -s \
- | awk '{print $$1}' \
- | awk -F '-' '{print $$3}' | sed 's/^0/ /g'); \
- date=$$(echo $${date} \
- | awk '{print $$1, "'"$${day}"'", $$3, $$4, $$5, $$6}'); \
- hash=$$(git show HEAD --format="format:%H" -s); \
- echo "${PKGNAME} ($${version}) unstable; urgency=low"; \
- echo; \
- echo " * Generated from git commit $${hash}."; \
- echo; \
- echo " -- $${author} $${date}"; \
- echo; \
- ) > build/${PKGNAME}-${VERSION}/debian/changelog
@find build/${PKGNAME}-${VERSION}/ -exec \
touch -t $$(date -d @$$(git show -s --format="format:%at") \
+"%Y%m%d%H%M.%S") {} \;
@@ -92,27 +47,3 @@ build/release-stamp:
@echo "Generated release tarball:"
@echo " $$(ls dist/${PKGNAME}-${VERSION}.tar.gz)"
@touch build/release-stamp
-
-deb: release build/deb-stamp
-build/deb-stamp:
- @echo "Building debian packages..."
- @cd build/${PKGNAME}-${VERSION}; \
- dpkg-buildpackage -rfakeroot -us -uc
- @mv build/*_${VERSION}_*.deb dist/
- @echo "Generated debian packages:"
- @for pkg in $$(ls dist/*_${VERSION}_*.deb); do echo " $${pkg}"; done
- @touch build/deb-stamp
-
-rpm: release build/rpm-stamp
-build/rpm-stamp:
- @echo "Building rpm packages..."
- @mkdir -p build/rpm
- @build=$$(pwd)/build/rpm; dist=$$(pwd)/dist/; rpmbuild \
- --define "_topdir $${build}" --define "_sourcedir $${dist}" \
- --define "_rpmdir $${build}" --define "_buildir $${build}" \
- --define "_srcrpmdir $${build}" -ba build/${PKGNAME}-${VERSION}/*.spec
- @mv build/rpm/*-${VERSION}*.src.rpm dist/
- @mv build/rpm/*/*-${VERSION}*.rpm dist/
- @echo "Generated rpm packages:"
- @for pkg in $$(ls dist/*-${VERSION}*.rpm); do echo " $${pkg}"; done
- @touch build/rpm-stamp
diff --git a/README.md b/README.md
index d3081d4..4cef117 100644
--- a/README.md
+++ b/README.md
@@ -20,15 +20,13 @@ targetcli-fb mailing should be used for configshell-fb discussion.
* Bugs: [GitHub](https://github.com/open-iscsi/configshell-fb/issues) or [Trac](https://fedorahosted.org/targetcli-fb/)
* Tarballs: [fedorahosted](https://fedorahosted.org/releases/t/a/targetcli-fb/)
-In-repo packaging
------------------
-Packaging scripts for RPM and DEB are included, but these are to make end-user
-custom packaging easier -- distributions tend to maintain their own packaging
-scripts separately. If you run into issues with packaging, start with opening
-a bug on your distro's bug reporting system.
-
-Some people do use these scripts, so we want to keep them around. Fixes for
-any breakage you encounter are welcome.
+Packages
+--------
+configshell-fb is packaged for a number of Linux distributions
+including RHEL,
+[Fedora](https://apps.fedoraproject.org/packages/python-configshell),
+openSUSE, Arch Linux, and
+[Debian](https://tracker.debian.org/pkg/python-configshell-fb).
"fb" -- "free branch"
---------------------
diff --git a/debian/README.Debian b/debian/README.Debian
deleted file mode 100644
index 78a1f14..0000000
--- a/debian/README.Debian
+++ /dev/null
@@ -1,13 +0,0 @@
-Copyright (c) 2011-2013 by Datera, Inc
-
-Licensed under the Apache License, Version 2.0 (the "License"); you may
-not use this file except in compliance with the License. You may obtain
-a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-Unless required by applicable law or agreed to in writing, software
-distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
-WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
-License for the specific language governing permissions and limitations
-under the License.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index 7f8f011..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/debian/control b/debian/control
deleted file mode 100644
index 1754389..0000000
--- a/debian/control
+++ /dev/null
@@ -1,32 +0,0 @@
-Source: configshell-fb
-Section: python
-Priority: optional
-Maintainer: Andy Grover <agrover@redhat.com>
-Build-Depends: debhelper(>= 8), python, python3, python-setuptools, python3-setuptools, python-epydoc, python-pyparsing
-Standards-Version: 3.9.4
-X-Python-Version: >= 2.6
-X-Python3-Version: >= 3.1
-
-Package: python-configshell-fb-docs
-Architecture: all
-Description: Framework to create CLI interfaces (Documentation).
- .
- This package contains the documentation of the configshell library (free branch).
-
-Package: python-configshell-fb
-Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-pyparsing, python-urwid (>=0.9.9), python-six
-Suggests: python-configshell-fb-docs
-Conflicts: python-configshell
-Provides: ${python:Provides}
-Description: Framework to create CLI interfaces (Python 2).
- .
- This package contains the configshell library (free branch).
-
-Package: python3-configshell-fb
-Architecture: all
-Depends: ${python3:Depends}, ${misc:Depends}, python3-pyparsing, python3-urwid (>=0.9.9), python3-six
-Suggests: python-configshell-fb-docs
-Description: Framework to create CLI interfaces (Python 3).
- .
- This package contains the configshell library (free branch, Python 3).
diff --git a/debian/copyright b/debian/copyright
deleted file mode 100644
index f2c98df..0000000
--- a/debian/copyright
+++ /dev/null
@@ -1,21 +0,0 @@
-This package was originally debianized by Jerome Martin <jxm@risingtidesystems.com>
-on Thu Sep 09 23:13:01 CET 2010. It is currently maintained by Andy Grover
-<andy@groveronline.com>.
-
-Upstream Author: Jerome Martin <jxm@risingtidesystems.com>
-
-This file is part of ConfigShell.
-Copyright (c) 2011-2013 by Datera, Inc
-
-Licensed under the Apache License, Version 2.0 (the "License"); you may
-not use this file except in compliance with the License. You may obtain
-a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-Unless required by applicable law or agreed to in writing, software
-distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
-WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
-License for the specific language governing permissions and limitations
-under the License.
-
diff --git a/debian/python-configshell-fb-docs.doc-base b/debian/python-configshell-fb-docs.doc-base
deleted file mode 100644
index df6a17a..0000000
--- a/debian/python-configshell-fb-docs.doc-base
+++ /dev/null
@@ -1,9 +0,0 @@
-Document: python-configshell-fb
-Title: python-configshell documentation
-Author: Jerome Martin <jxm@risingtidesystems.com>
-Abstract: configshell is a library which is used to create cli interfaces
-Section: Programming/Python
-
-Format: HTML
-Index: /usr/share/doc/python-configshell-fb-docs/html/index.html
-Files: /usr/share/doc/python-configshell-fb-docs/html/*.html
diff --git a/debian/python-configshell-fb.install b/debian/python-configshell-fb.install
deleted file mode 100644
index b2cc136..0000000
--- a/debian/python-configshell-fb.install
+++ /dev/null
@@ -1 +0,0 @@
-usr/lib/python2*
diff --git a/debian/python3-configshell-fb.install b/debian/python3-configshell-fb.install
deleted file mode 100644
index 4606faa..0000000
--- a/debian/python3-configshell-fb.install
+++ /dev/null
@@ -1 +0,0 @@
-usr/lib/python3*
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 24b99be..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/usr/bin/make -f
-
-build_dir = build
-install_dir = $(CURDIR)/debian/tmp
-pkgname = configshell-fb
-name = configshell
-
-#export DH_VERBOSE=1
-
-PYTHON2=$(shell pyversions -vr)
-PYTHON3=$(shell py3versions -vr)
-
-# prevent internet access to use PyPi
-export http_proxy = http://127.0.0.1:9
-
-
-%:
- echo "debug dh: $@"
- dh $@ --with python2,python3
-
-
-build-python%:
- echo "debug: $@"
- python$* setup.py build
-
-override_dh_auto_build: $(PYTHON3:%=build-python%) $(PYTHON2:%=build-python%)
- dh_auto_build
-
-
-install-python%:
- echo "debug: $@"
- python$* setup.py install --root=$(install_dir) --install-layout=deb
-
-override_dh_auto_install: $(PYTHON3:%=install-python%) $(PYTHON2:%=install-python%)
- dh_auto_install
-
-
-override_dh_installdocs:
- cd $(build_dir); epydoc --no-sourcecode --html -n $(pkgname) \
- --exclude configobj ../$(name)/*.py
- dh_installdocs $(build_dir)/html
-
-override_dh_auto_clean:
- dh_auto_clean
- rm -rf build
- rm -rf *.egg-info
diff --git a/debian/source/format b/debian/source/format
deleted file mode 100644
index 89ae9db..0000000
--- a/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (native)
diff --git a/rpm/python-configshell.spec.tmpl b/rpm/python-configshell.spec.tmpl
deleted file mode 100644
index cd301c0..0000000
--- a/rpm/python-configshell.spec.tmpl
+++ /dev/null
@@ -1,44 +0,0 @@
-%define oname configshell-fb
-
-Name: python-configshell
-License: Apache License 2.0
-Group: System Environment/Libraries
-Summary: A framework to implement simple but nice CLIs.
-Version: VERSION
-Release: 1%{?dist}
-URL: http://www.risingtidesystems.com/git/
-Source: %{oname}-%{version}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-rpmroot
-BuildArch: noarch
-BuildRequires: python-devel
-Requires: pyparsing, python-urwid >= 0.9.9, epydoc
-Vendor: Datera, Inc.
-
-%description
-A framework to implement simple but nice command-line interfaces.
-
-%prep
-%setup -q -n %{oname}-%{version}
-
-%build
-%{__python} setup.py build
-mkdir -p doc/
-epydoc --no-sourcecode --html -n %{oname} --exclude configobj configshell_fb/*.py
-mv html doc/
-
-%install
-rm -rf %{buildroot}
-%{__python} setup.py install --skip-build --root %{buildroot} --prefix=usr
-mkdir -p %{buildroot}/usr/share/doc/python-configshell-doc-%{version}
-cp -r doc/* %{buildroot}/usr/share/doc/python-configshell-doc-%{version}/
-
-%clean
-rm -rf %{buildroot}
-
-%files
-%defattr(-,root,root,-)
-%{python_sitelib}
-/usr/share/doc/python-configshell-doc-%{version}
-%doc examples COPYING README.md
-
-%changelog