summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-03-02 09:04:30 +0100
committerPetr Vaněk <arkamar@atlas.cz>2023-03-02 09:04:30 +0100
commiteee02decb9b84927b8c299bcc962523e7458fb21 (patch)
treedc6663ca5b85c869f4087ec38080ada9af8dcd5c
parent50d5ffe9f213a53588cec88c9919c816b3fa7736 (diff)
downloadconfigshell-fb-eee02decb9b84927b8c299bcc962523e7458fb21.tar.gz
setup.py: relax pyparsing version restriction
The need to restrict pyparsing to <3.0 seems to be unnecessary anymore. It is from the time when pyparsing-3 was pre-release candidate which was causing build failures. Original commit [1] locked pyparsing on specific version which was later relaxed to <3.0 [2]. pyparsing is currently in version 3.0.9 and it works fine with configshell-fb. [1] ec7ca0ee13a2 ("setup.py: lets stick to pyparsing v2.4.7") [2] f1fd5a920760 ("setup.py: specify a version range for pyparsing")
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 502f195..ab7bd33 100755
--- a/setup.py
+++ b/setup.py
@@ -42,7 +42,7 @@ setup(
url = 'http://github.com/open-iscsi/configshell-fb',
packages = ['configshell', 'configshell_fb'],
install_requires = [
- 'pyparsing >=2.0.2,<3.0',
+ 'pyparsing >=2.0.2',
'six',
'urwid',
],