summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrasanna Kumar Kalever <prasanna.kalever@redhat.com>2020-04-06 21:44:46 +0530
committerPrasanna Kumar Kalever <prasanna.kalever@redhat.com>2020-05-12 15:28:22 +0530
commitec7ca0ee13a2ad8a3d43fb1cb20bb012480dce0f (patch)
treec602938ab95658c817468cf78faa14d2e34050ae
parentda8f0cef114e7343a7ae96ff1db7c8c574f819be (diff)
downloadconfigshell-fb-ec7ca0ee13a2ad8a3d43fb1cb20bb012480dce0f.tar.gz
setup.py: lets stick to pyparsing v2.4.7
Currently setup.py is pulling pyparsing-3.0.0a1 which is a pre-release candidate, and is even failing to build. Since pyparsing is failing to build, configshell build is inturn failing. May be for now, lets stick to the stable release pyparsing-2.4.7 Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9b5c7d1..9b38eac 100755
--- a/setup.py
+++ b/setup.py
@@ -42,7 +42,7 @@ setup(
url = 'http://github.com/open-iscsi/configshell-fb',
packages = ['configshell', 'configshell_fb'],
install_requires = [
- 'pyparsing >= 2.0.2',
+ 'pyparsing == 2.4.7',
'six',
'urwid',
],