summaryrefslogtreecommitdiff
path: root/doxygen/html/navtree.js
diff options
context:
space:
mode:
Diffstat (limited to 'doxygen/html/navtree.js')
-rw-r--r--doxygen/html/navtree.js352
1 files changed, 352 insertions, 0 deletions
diff --git a/doxygen/html/navtree.js b/doxygen/html/navtree.js
new file mode 100644
index 0000000..d34ea31
--- /dev/null
+++ b/doxygen/html/navtree.js
@@ -0,0 +1,352 @@
+var NAVTREE =
+[
+ [ "Cmd2", "index.html", [
+ [ "Class List", "annotated.html", [
+ [ "cmd2::Borg", "classcmd2_1_1Borg.html", null ],
+ [ "cmd2::Cmd", "classcmd2_1_1Cmd.html", null ],
+ [ "cmd2::Cmd2TestCase", "classcmd2_1_1Cmd2TestCase.html", null ],
+ [ "cmd2::EmbeddedConsoleExit", "classcmd2_1_1EmbeddedConsoleExit.html", null ],
+ [ "cmd2::EmptyStatement", "classcmd2_1_1EmptyStatement.html", null ],
+ [ "cmd2::History", "classcmd2_1_1History.html", null ],
+ [ "cmd2::HistoryItem", "classcmd2_1_1HistoryItem.html", null ],
+ [ "cmd2::NotSettableError", "classcmd2_1_1NotSettableError.html", null ],
+ [ "cmd2::OptionParser", "classcmd2_1_1OptionParser.html", null ],
+ [ "cmd2::OutputTrap", "classcmd2_1_1OutputTrap.html", null ],
+ [ "cmd2::ParsedString", "classcmd2_1_1ParsedString.html", null ],
+ [ "cmd2::PasteBufferError", "classcmd2_1_1PasteBufferError.html", null ],
+ [ "cmd2::Statekeeper", "classcmd2_1_1Statekeeper.html", null ],
+ [ "cmd2::StubbornDict", "classcmd2_1_1StubbornDict.html", null ],
+ [ "example::CmdLineApp", "classexample_1_1CmdLineApp.html", null ],
+ [ "pirate2::Pirate", "classpirate2_1_1Pirate.html", null ],
+ [ "pirate3::Pirate", "classpirate3_1_1Pirate.html", null ],
+ [ "pirate4::Pirate", "classpirate4_1_1Pirate.html", null ],
+ [ "pirate5::Pirate", "classpirate5_1_1Pirate.html", null ],
+ [ "pirate6::Pirate", "classpirate6_1_1Pirate.html", null ],
+ [ "pirate7::Pirate", "classpirate7_1_1Pirate.html", null ],
+ [ "pirate8::Pirate", "classpirate8_1_1Pirate.html", null ],
+ [ "pirate::Pirate", "classpirate_1_1Pirate.html", null ]
+ ] ],
+ [ "Class Index", "classes.html", null ],
+ [ "Class Hierarchy", "hierarchy.html", [
+ [ "cmd2::Borg", "classcmd2_1_1Borg.html", [
+ [ "cmd2::OutputTrap", "classcmd2_1_1OutputTrap.html", null ]
+ ] ],
+ [ "cmd2::Cmd", "classcmd2_1_1Cmd.html", [
+ [ "example::CmdLineApp", "classexample_1_1CmdLineApp.html", null ],
+ [ "pirate6::Pirate", "classpirate6_1_1Pirate.html", null ],
+ [ "pirate7::Pirate", "classpirate7_1_1Pirate.html", null ],
+ [ "pirate8::Pirate", "classpirate8_1_1Pirate.html", null ]
+ ] ],
+ [ "cmd2::Cmd2TestCase", "classcmd2_1_1Cmd2TestCase.html", null ],
+ [ "cmd2::EmbeddedConsoleExit", "classcmd2_1_1EmbeddedConsoleExit.html", null ],
+ [ "cmd2::EmptyStatement", "classcmd2_1_1EmptyStatement.html", null ],
+ [ "cmd2::History", "classcmd2_1_1History.html", null ],
+ [ "cmd2::HistoryItem", "classcmd2_1_1HistoryItem.html", null ],
+ [ "cmd2::NotSettableError", "classcmd2_1_1NotSettableError.html", null ],
+ [ "cmd2::OptionParser", "classcmd2_1_1OptionParser.html", null ],
+ [ "cmd2::ParsedString", "classcmd2_1_1ParsedString.html", null ],
+ [ "cmd2::PasteBufferError", "classcmd2_1_1PasteBufferError.html", null ],
+ [ "cmd2::Statekeeper", "classcmd2_1_1Statekeeper.html", null ],
+ [ "cmd2::StubbornDict", "classcmd2_1_1StubbornDict.html", null ],
+ [ "pirate2::Pirate", "classpirate2_1_1Pirate.html", null ],
+ [ "pirate3::Pirate", "classpirate3_1_1Pirate.html", null ],
+ [ "pirate4::Pirate", "classpirate4_1_1Pirate.html", null ],
+ [ "pirate5::Pirate", "classpirate5_1_1Pirate.html", null ],
+ [ "pirate::Pirate", "classpirate_1_1Pirate.html", null ]
+ ] ],
+ [ "Class Members", "functions.html", null ],
+ [ "Packages", "namespaces.html", [
+ [ "cmd2", "namespacecmd2.html", null ],
+ [ "conf", "namespaceconf.html", null ],
+ [ "example", "namespaceexample.html", null ],
+ [ "fileutil", "namespacefileutil.html", null ],
+ [ "graph", "namespacegraph.html", null ],
+ [ "ignoreBug", "namespaceignoreBug.html", null ],
+ [ "pirate", "namespacepirate.html", null ],
+ [ "pirate2", "namespacepirate2.html", null ],
+ [ "pirate3", "namespacepirate3.html", null ],
+ [ "pirate4", "namespacepirate4.html", null ],
+ [ "pirate5", "namespacepirate5.html", null ],
+ [ "pirate6", "namespacepirate6.html", null ],
+ [ "pirate7", "namespacepirate7.html", null ],
+ [ "pirate8", "namespacepirate8.html", null ],
+ [ "schematic", "namespaceschematic.html", null ],
+ [ "setup", "namespacesetup.html", null ]
+ ] ],
+ [ "Package Functions", "namespacemembers.html", null ],
+ [ "File List", "files.html", [
+ [ "/Users/amrogers/Developer/Projects/cmd2/cmd2.py", "cmd2_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/ignoreBug.py", "ignoreBug_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/setup.py", "setup_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/conf.py", "conf_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/fileutil.py", "fileutil_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/graph.py", "graph_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/pirate.py", "pirate_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/pirate2.py", "pirate2_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/pirate3.py", "pirate3_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/pirate4.py", "pirate4_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/pirate5.py", "pirate5_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/pirate6.py", "pirate6_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/pirate7.py", "pirate7_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/pirate8.py", "pirate8_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/docs/pycon2010/schematic.py", "schematic_8py.html", null ],
+ [ "/Users/amrogers/Developer/Projects/cmd2/example/example.py", "example_8py.html", null ]
+ ] ],
+ [ "Directories", "dirs.html", [
+ [ "Projects", "dir_e01452e30018b7d8a87d21a8fdf5052c.html", [
+ [ "cmd2", "dir_bfedb8cf204bc52dab598c696b63c3d6.html", [
+ [ "docs", "dir_5185d8a4f3d34c6a54b85ae5904b80ec.html", [
+ [ "pycon2010", "dir_a94d11e7025bc9c49b19e92232c5c310.html", null ]
+ ] ],
+ [ "example", "dir_9c53eb36d53ed9f246f40760bdb65b6a.html", null ]
+ ] ]
+ ] ]
+ ] ]
+ ] ]
+];
+
+function createIndent(o,domNode,node,level)
+{
+ if (node.parentNode && node.parentNode.parentNode)
+ {
+ createIndent(o,domNode,node.parentNode,level+1);
+ }
+ var imgNode = document.createElement("img");
+ if (level==0 && node.childrenData)
+ {
+ node.plus_img = imgNode;
+ node.expandToggle = document.createElement("a");
+ node.expandToggle.href = "javascript:void(0)";
+ node.expandToggle.onclick = function()
+ {
+ if (node.expanded)
+ {
+ $(node.getChildrenUL()).slideUp("fast");
+ if (node.isLast)
+ {
+ node.plus_img.src = node.relpath+"ftv2plastnode.png";
+ }
+ else
+ {
+ node.plus_img.src = node.relpath+"ftv2pnode.png";
+ }
+ node.expanded = false;
+ }
+ else
+ {
+ expandNode(o, node, false);
+ }
+ }
+ node.expandToggle.appendChild(imgNode);
+ domNode.appendChild(node.expandToggle);
+ }
+ else
+ {
+ domNode.appendChild(imgNode);
+ }
+ if (level==0)
+ {
+ if (node.isLast)
+ {
+ if (node.childrenData)
+ {
+ imgNode.src = node.relpath+"ftv2plastnode.png";
+ }
+ else
+ {
+ imgNode.src = node.relpath+"ftv2lastnode.png";
+ domNode.appendChild(imgNode);
+ }
+ }
+ else
+ {
+ if (node.childrenData)
+ {
+ imgNode.src = node.relpath+"ftv2pnode.png";
+ }
+ else
+ {
+ imgNode.src = node.relpath+"ftv2node.png";
+ domNode.appendChild(imgNode);
+ }
+ }
+ }
+ else
+ {
+ if (node.isLast)
+ {
+ imgNode.src = node.relpath+"ftv2blank.png";
+ }
+ else
+ {
+ imgNode.src = node.relpath+"ftv2vertline.png";
+ }
+ }
+ imgNode.border = "0";
+}
+
+function newNode(o, po, text, link, childrenData, lastNode)
+{
+ var node = new Object();
+ node.children = Array();
+ node.childrenData = childrenData;
+ node.depth = po.depth + 1;
+ node.relpath = po.relpath;
+ node.isLast = lastNode;
+
+ node.li = document.createElement("li");
+ po.getChildrenUL().appendChild(node.li);
+ node.parentNode = po;
+
+ node.itemDiv = document.createElement("div");
+ node.itemDiv.className = "item";
+
+ node.labelSpan = document.createElement("span");
+ node.labelSpan.className = "label";
+
+ createIndent(o,node.itemDiv,node,0);
+ node.itemDiv.appendChild(node.labelSpan);
+ node.li.appendChild(node.itemDiv);
+
+ var a = document.createElement("a");
+ node.labelSpan.appendChild(a);
+ node.label = document.createTextNode(text);
+ a.appendChild(node.label);
+ if (link)
+ {
+ a.href = node.relpath+link;
+ }
+ else
+ {
+ if (childrenData != null)
+ {
+ a.className = "nolink";
+ a.href = "javascript:void(0)";
+ a.onclick = node.expandToggle.onclick;
+ node.expanded = false;
+ }
+ }
+
+ node.childrenUL = null;
+ node.getChildrenUL = function()
+ {
+ if (!node.childrenUL)
+ {
+ node.childrenUL = document.createElement("ul");
+ node.childrenUL.className = "children_ul";
+ node.childrenUL.style.display = "none";
+ node.li.appendChild(node.childrenUL);
+ }
+ return node.childrenUL;
+ };
+
+ return node;
+}
+
+function showRoot()
+{
+ var headerHeight = $("#top").height();
+ var footerHeight = $("#nav-path").height();
+ var windowHeight = $(window).height() - headerHeight - footerHeight;
+ navtree.scrollTo('#selected',0,{offset:-windowHeight/2});
+}
+
+function expandNode(o, node, imm)
+{
+ if (node.childrenData && !node.expanded)
+ {
+ if (!node.childrenVisited)
+ {
+ getNode(o, node);
+ }
+ if (imm)
+ {
+ $(node.getChildrenUL()).show();
+ }
+ else
+ {
+ $(node.getChildrenUL()).slideDown("fast",showRoot);
+ }
+ if (node.isLast)
+ {
+ node.plus_img.src = node.relpath+"ftv2mlastnode.png";
+ }
+ else
+ {
+ node.plus_img.src = node.relpath+"ftv2mnode.png";
+ }
+ node.expanded = true;
+ }
+}
+
+function getNode(o, po)
+{
+ po.childrenVisited = true;
+ var l = po.childrenData.length-1;
+ for (var i in po.childrenData)
+ {
+ var nodeData = po.childrenData[i];
+ po.children[i] = newNode(o, po, nodeData[0], nodeData[1], nodeData[2],
+ i==l);
+ }
+}
+
+function findNavTreePage(url, data)
+{
+ var nodes = data;
+ var result = null;
+ for (var i in nodes)
+ {
+ var d = nodes[i];
+ if (d[1] == url)
+ {
+ return new Array(i);
+ }
+ else if (d[2] != null) // array of children
+ {
+ result = findNavTreePage(url, d[2]);
+ if (result != null)
+ {
+ return (new Array(i).concat(result));
+ }
+ }
+ }
+ return null;
+}
+
+function initNavTree(toroot,relpath)
+{
+ var o = new Object();
+ o.toroot = toroot;
+ o.node = new Object();
+ o.node.li = document.getElementById("nav-tree-contents");
+ o.node.childrenData = NAVTREE;
+ o.node.children = new Array();
+ o.node.childrenUL = document.createElement("ul");
+ o.node.getChildrenUL = function() { return o.node.childrenUL; };
+ o.node.li.appendChild(o.node.childrenUL);
+ o.node.depth = 0;
+ o.node.relpath = relpath;
+
+ getNode(o, o.node);
+
+ o.breadcrumbs = findNavTreePage(toroot, NAVTREE);
+ if (o.breadcrumbs == null)
+ {
+ o.breadcrumbs = findNavTreePage("index.html",NAVTREE);
+ }
+ if (o.breadcrumbs != null && o.breadcrumbs.length>0)
+ {
+ var p = o.node;
+ for (var i in o.breadcrumbs)
+ {
+ var j = o.breadcrumbs[i];
+ p = p.children[j];
+ expandNode(o,p,true);
+ }
+ p.itemDiv.className = p.itemDiv.className + " selected";
+ p.itemDiv.id = "selected";
+ $(window).load(showRoot);
+ }
+}
+