summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Leonhardt <todd.leonhardt@gmail.com>2017-07-08 15:34:17 -0400
committerTodd Leonhardt <todd.leonhardt@gmail.com>2017-07-08 15:34:17 -0400
commitd1efcb38434476afb3e03795f118b00d2e0653f7 (patch)
tree3cae742baafa6e449a418c53d8a8a104920fa378
parent891fe3f34e2896b9c8d94a8c47c2c06f64f1ab93 (diff)
downloadcmd2-git-0.7.5.tar.gz
Bump version to 0.7.5 (from 0.7.5a)0.7.5
-rwxr-xr-xcmd2.py2
-rw-r--r--docs/conf.py2
-rwxr-xr-xsetup.py2
-rw-r--r--tests/test_cmd2.py2
4 files changed, 4 insertions, 4 deletions
diff --git a/cmd2.py b/cmd2.py
index 59d7cbc1..ed194e3b 100755
--- a/cmd2.py
+++ b/cmd2.py
@@ -75,7 +75,7 @@ try:
except ImportError:
pass
-__version__ = '0.7.5a'
+__version__ = '0.7.5'
# Pyparsing enablePackrat() can greatly speed up parsing, but problems have been seen in Python 3 in the past
pyparsing.ParserElement.enablePackrat()
diff --git a/docs/conf.py b/docs/conf.py
index fa559859..296aad60 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -62,7 +62,7 @@ author = 'Catherine Devlin and Todd Leonhardt'
# The short X.Y version.
version = '0.7'
# The full version, including alpha/beta/rc tags.
-release = '0.7.4'
+release = '0.7.5'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 79cb18be..a5e71028 100755
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ Setuptools setup file, used to install or test 'cmd2'
"""
from setuptools import setup
-VERSION = '0.7.5a'
+VERSION = '0.7.5'
DESCRIPTION = "cmd2 - a tool for building interactive command line applications in Python"
LONG_DESCRIPTION = """cmd2 is a tool for building interactive command line applications in Python. Its goal is to make
it quick and easy for developers to build feature-rich and user-friendly interactive command line applications. It
diff --git a/tests/test_cmd2.py b/tests/test_cmd2.py
index a32fba76..f6781a8d 100644
--- a/tests/test_cmd2.py
+++ b/tests/test_cmd2.py
@@ -22,7 +22,7 @@ from conftest import run_cmd, normalize, BASE_HELP, HELP_HISTORY, SHORTCUTS_TXT,
def test_ver():
- assert cmd2.__version__ == '0.7.5a'
+ assert cmd2.__version__ == '0.7.5'
def test_empty_statement(base_app):