summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@gmail.com>2013-09-23 12:52:04 -0700
committerDoug Hellmann <doug.hellmann@gmail.com>2013-09-23 12:52:04 -0700
commit8520f67ef0f60960493c73ebc22afceb87f0fecf (patch)
tree7ff525c3a131fa442ebb7172ad132899aa5bc562
parentff3ac6435ba27a29cdc015d0d7df45c245a7a5e2 (diff)
parent993972982739b2db3028278cb4d99be2a713d09c (diff)
downloadcliff-8520f67ef0f60960493c73ebc22afceb87f0fecf.tar.gz
Merge pull request #48 from dreamhost/pyparsing-update
Pyparsing update
-rw-r--r--.travis.yml2
-rw-r--r--demoapp/setup.py2
-rw-r--r--docs/source/history.rst5
-rw-r--r--setup.py14
-rw-r--r--tox.ini2
5 files changed, 11 insertions, 14 deletions
diff --git a/.travis.yml b/.travis.yml
index eb4857e..ea35c0e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -2,5 +2,7 @@ language: python
python:
- 2.7
- 3.2
+ - 3.3
+ - pypy
install: pip install -r test-requirements.txt
script: nosetests -d \ No newline at end of file
diff --git a/demoapp/setup.py b/demoapp/setup.py
index f507497..4bef32e 100644
--- a/demoapp/setup.py
+++ b/demoapp/setup.py
@@ -41,7 +41,7 @@ setup(
scripts=[],
provides=[],
- install_requires=['distribute', 'cliff'],
+ install_requires=['cliff'],
namespace_packages=[],
packages=find_packages(),
diff --git a/docs/source/history.rst b/docs/source/history.rst
index 86c76f8..5e068d8 100644
--- a/docs/source/history.rst
+++ b/docs/source/history.rst
@@ -2,6 +2,11 @@
Release History
=================
+dev
+
+- Update the pyparsing dependency to a version that supports both
+ Python 2 and Python 3.
+
1.4.4
- Provide better error handling for unknown commands run from the
diff --git a/setup.py b/setup.py
index 1ccb7b0..e58420a 100644
--- a/setup.py
+++ b/setup.py
@@ -17,20 +17,10 @@ except IOError:
install_requires = [
'PrettyTable>=0.6,<0.8',
- # Restrict cliff from bringing in cmd2 0.6.6 until the problem
- # with the Python 3-only code is resolved.
- 'cmd2>=0.6.4,<0.6.6',
+ 'pyparsing>=2.0.1',
+ 'cmd2>=0.6.7',
]
-# We need a different version of PyParsing, depending on which version
-# of Python we're using. cmd2 should have this set properly, but until
-# there is a release declare the dependency ourselves.
-# http://trac-hg.assembla.com/python-cmd2/rev/a5f3d5a89d6c
-if sys.version_info[0] < 3:
- install_requires.append('pyparsing==1.5.7')
-else:
- install_requires.append('pyparsing>=2.0.0')
-
try:
import argparse # noqa
except ImportError:
diff --git a/tox.ini b/tox.ini
index bffdf13..3c07077 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py32,py33,style
+envlist = py26,py27,py32,py33,pypy,style
[testenv]
distribute = False