summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2013-09-09 09:38:17 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2013-09-23 15:45:23 -0400
commit6a35ba1b0d7b40eaa184769400ab7445427925dc (patch)
tree5868ff8e2a337995585b539fefff409bbec45b46
parentff3ac6435ba27a29cdc015d0d7df45c245a7a5e2 (diff)
downloadcliff-6a35ba1b0d7b40eaa184769400ab7445427925dc.tar.gz
Update pyparsing dependency to 2.0.1
Go ahead and require the version of pyparsing that supports python 2 and 3. Change-Id: Icdeb7c4a4aeaab9fcc4a44b091a068f91553adf6
-rw-r--r--demoapp/setup.py2
-rw-r--r--docs/source/history.rst5
-rw-r--r--setup.py14
3 files changed, 8 insertions, 13 deletions
diff --git a/demoapp/setup.py b/demoapp/setup.py
index f507497..4bef32e 100644
--- a/demoapp/setup.py
+++ b/demoapp/setup.py
@@ -41,7 +41,7 @@ setup(
scripts=[],
provides=[],
- install_requires=['distribute', 'cliff'],
+ install_requires=['cliff'],
namespace_packages=[],
packages=find_packages(),
diff --git a/docs/source/history.rst b/docs/source/history.rst
index 86c76f8..5e068d8 100644
--- a/docs/source/history.rst
+++ b/docs/source/history.rst
@@ -2,6 +2,11 @@
Release History
=================
+dev
+
+- Update the pyparsing dependency to a version that supports both
+ Python 2 and Python 3.
+
1.4.4
- Provide better error handling for unknown commands run from the
diff --git a/setup.py b/setup.py
index 1ccb7b0..e58420a 100644
--- a/setup.py
+++ b/setup.py
@@ -17,20 +17,10 @@ except IOError:
install_requires = [
'PrettyTable>=0.6,<0.8',
- # Restrict cliff from bringing in cmd2 0.6.6 until the problem
- # with the Python 3-only code is resolved.
- 'cmd2>=0.6.4,<0.6.6',
+ 'pyparsing>=2.0.1',
+ 'cmd2>=0.6.7',
]
-# We need a different version of PyParsing, depending on which version
-# of Python we're using. cmd2 should have this set properly, but until
-# there is a release declare the dependency ourselves.
-# http://trac-hg.assembla.com/python-cmd2/rev/a5f3d5a89d6c
-if sys.version_info[0] < 3:
- install_requires.append('pyparsing==1.5.7')
-else:
- install_requires.append('pyparsing>=2.0.0')
-
try:
import argparse # noqa
except ImportError: