summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2013-08-13 13:23:35 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2013-08-13 13:23:35 -0400
commit300aec33a3e5299dd3bf3996578c2822914de512 (patch)
treed5f7d19700dfa399631f6e6f3ddc06c6f91688ed
parent50de738446d5e4e1ad085b6d8faf41c640c6159f (diff)
downloadcliff-300aec33a3e5299dd3bf3996578c2822914de512.tar.gz
Tighten requirements on cmd2
Work around for https://bitbucket.org/catherinedevlin/cmd2/issue/6/packaging-bug Change-Id: I8a18825d0660c21649a8d838635832959eee8a40
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 00fe75e..88094a2 100644
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,9 @@ except IOError:
install_requires = [
'PrettyTable>=0.6,<0.8',
- 'cmd2>=0.6.4',
+ # Restrict cliff from bringing in cmd2 0.6.6 until the problem
+ # with the Python 3-only code is resolved.
+ 'cmd2>=0.6.4,<0.6.6',
]
# We need a different version of PyParsing, depending on which version