summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-05-07 15:45:51 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-05-07 15:45:51 -0400
commitdfe456fa6b6eadda8ba77fc74ad043e2b3f9d050 (patch)
treef182a768322d16b0303f3cda85dd3ee5433f2e96
parentf3efefbc542f557d0b7f3f33fecb10a5e7a318b1 (diff)
downloadcliff-tablib-dfe456fa6b6eadda8ba77fc74ad043e2b3f9d050.tar.gz
remove hard version requirement to unbreak the OpenStack build
-rw-r--r--docs/source/conf.py2
-rw-r--r--docs/source/history.rst5
-rw-r--r--setup.py5
3 files changed, 9 insertions, 3 deletions
diff --git a/docs/source/conf.py b/docs/source/conf.py
index e84023b..cfcbf28 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -48,7 +48,7 @@ copyright = u'2012, Doug Hellmann'
# built documents.
#
# The short X.Y version.
-version = '0.5'
+version = '0.5.1'
# The full version, including alpha/beta/rc tags.
release = version
diff --git a/docs/source/history.rst b/docs/source/history.rst
index 395829a..eeaa92a 100644
--- a/docs/source/history.rst
+++ b/docs/source/history.rst
@@ -2,6 +2,11 @@
Release History
=================
+0.5.1
+
+ - Remove pinned version requirement for PrettyTable until the
+ OpenStack clients catch up to the API change.
+
0.5
- Asking for help about a command by prefix lists all matching
diff --git a/setup.py b/setup.py
index f75b132..5febd0e 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
PROJECT = 'cliff'
# Change docs/source/conf.py too!
-VERSION = '0.5'
+VERSION = '0.5.1'
# Bootstrap installation of Distribute
import distribute_setup
@@ -146,7 +146,8 @@ setup(
provides=['cliff',
],
install_requires=['distribute',
- 'PrettyTable>=0.6',
+ # disabled until OpenStack catches up 'PrettyTable>=0.6',
+ 'PrettyTable',
'cmd2',
'tablib',
],