summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Rigo <arigo@tunes.org>2015-05-18 18:32:41 +0200
committerArmin Rigo <arigo@tunes.org>2015-05-18 18:32:41 +0200
commitb25af8e0c5a84b4b9680b8611459598b7a889862 (patch)
treee862e16855a8b853a2e4ccbcb05d02d4dd0112a7
parentb8c42c3ca792c211a967bc8870b488407804e01c (diff)
downloadcffi-b25af8e0c5a84b4b9680b8611459598b7a889862.tar.gz
Add a mostly empty "whatsnew.rst"
-rw-r--r--doc/source/index.rst1
-rw-r--r--doc/source/overview.rst5
-rw-r--r--doc/source/whatsnew.rst19
3 files changed, 24 insertions, 1 deletions
diff --git a/doc/source/index.rst b/doc/source/index.rst
index 9b211e4..76a84b5 100644
--- a/doc/source/index.rst
+++ b/doc/source/index.rst
@@ -9,6 +9,7 @@ interface declarations written in C.
.. toctree::
:maxdepth: 2
+ whatsnew
installation
overview
using
diff --git a/doc/source/overview.rst b/doc/source/overview.rst
index acb23b3..0333099 100644
--- a/doc/source/overview.rst
+++ b/doc/source/overview.rst
@@ -41,6 +41,8 @@ arguments. In the above example it would be ``b"world"`` and ``b"hi
there, %s!\n"``. In general it is ``somestring.encode(myencoding)``.
+.. _out-of-line-abi-level:
+
Out-of-line example (ABI level, out-of-line)
--------------------------------------------
@@ -49,7 +51,7 @@ main program's modules. Instead, you can rewrite it as follows. It
massively reduces the import times, because it is slow to parse a
large C header. It also allows you to do more detailed checkings
during build-time without worrying about performance (e.g. calling
-``cdef()`` several times with small pieces of declarations, based
+``cdef()`` many times with small pieces of declarations, based
on the version of libraries detected on the system).
.. code-block:: python
@@ -93,6 +95,7 @@ you can say in the ``setup.py``::
)
+.. _out-of-line-api-level:
.. _real-example:
Real example (API level, out-of-line)
diff --git a/doc/source/whatsnew.rst b/doc/source/whatsnew.rst
new file mode 100644
index 0000000..f645f97
--- /dev/null
+++ b/doc/source/whatsnew.rst
@@ -0,0 +1,19 @@
+======================
+What's New
+======================
+
+
+1.0.0
+=====
+
+* The main news item is out-of-line module generation:
+
+ * `for ABI level`_, with ``ffi.dlopen()``
+
+ * `for API level`_, which used to be with ``ffi.verify()``, now deprecated
+
+* (this page will list what is new from all versions from 1.0.0
+ forward.)
+
+.. _`for ABI level`: overview.html#out-of-line-abi-level
+.. _`for API level`: overview.html#out-of-line-api-level