summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Davis <mrd@redhat.com>2022-06-30 11:09:19 -0700
committerMatt Davis <mrd@redhat.com>2022-06-30 11:09:19 -0700
commit8c263bf1fee1b303d64b226bdd7f1f89cc9ef699 (patch)
treec23c46e30f4ada13b30703b49e67ce05ba707dfb
parenteaa9538f4130d7953297e1926ec4c08bd6c8d9f0 (diff)
parenta225d2a76ee835a5d1d9e756655e3b3a6892e5b4 (diff)
downloadcffi-8c263bf1fee1b303d64b226bdd7f1f89cc9ef699.tar.gz
hg merge release-1.15 to default
-rw-r--r--.github/workflows/ci.yaml26
-rw-r--r--doc/source/installation.rst6
2 files changed, 27 insertions, 5 deletions
diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
index d30f9b0..2ec3681 100644
--- a/.github/workflows/ci.yaml
+++ b/.github/workflows/ci.yaml
@@ -50,14 +50,36 @@ jobs:
- spec: cp39-musllinux_i686
- spec: cp310-musllinux_i686
- spec: cp311-musllinux_i686
+ - spec: cp36-manylinux_ppc64le
+ foreign_arch: true
+ test_args: '{project}/c'
+ - spec: cp37-manylinux_ppc64le
+ foreign_arch: true
+ test_args: '{project}/c'
+ - spec: cp38-manylinux_ppc64le
+ foreign_arch: true
+ test_args: '{project}/c'
+ - spec: cp39-manylinux_ppc64le
+ foreign_arch: true
+ test_args: '{project}/c'
+ - spec: cp310-manylinux_ppc64le
+ foreign_arch: true
+ test_args: '{project}/c'
+ - spec: cp311-manylinux_ppc64le
+ foreign_arch: true
+ test_args: '{project}/c'
steps:
- name: clone repo
uses: actions/checkout@v2
+ - name: configure docker foreign arch support
+ uses: docker/setup-qemu-action@v1
+ if: ${{ matrix.foreign_arch || false }}
+
- name: build/test wheels
env:
CFLAGS: -Dffi_call=cffistatic_ffi_call # override name for ffi_call to break hard if we linked against someone else's libffi
- CIBW_ARCHS_LINUX: auto
+ CIBW_ARCHS_LINUX: all
CIBW_BUILD: ${{ matrix.spec }}
CIBW_BEFORE_BUILD: |
set -eux && \
@@ -73,7 +95,7 @@ jobs:
CIBW_MANYLINUX_I686_IMAGE: ${{ matrix.manylinux_img || '' }}
CIBW_PRERELEASE_PYTHONS: 'True'
CIBW_TEST_REQUIRES: pytest
- CIBW_TEST_COMMAND: PYTHONUNBUFFERED=1 python -m pytest {project}
+ CIBW_TEST_COMMAND: PYTHONUNBUFFERED=1 python -m pytest ${{ matrix.test_args || '{project}' }} # default to test all
run: |
python -m pip install --upgrade "${{ matrix.cibw_version || 'cibuildwheel' }}"
diff --git a/doc/source/installation.rst b/doc/source/installation.rst
index 4859c83..e198f0d 100644
--- a/doc/source/installation.rst
+++ b/doc/source/installation.rst
@@ -54,11 +54,11 @@ Download and Installation:
* Checksums of the "source" package version 1.15.1:
- - MD5: ...
+ - MD5: f493860a6e98cd0c4178149568a6b4f6
- - SHA1: ...
+ - SHA1: c42a46cd11f6153f299cf10e9c236e8b2a143c21
- - SHA256: ...
+ - SHA256: d400bfb9a37b1351253cb402671cea7e89bdecc294e8016a707f6d1d8ac934f9
* Or grab the most current version from the `Heptapod page`_:
``hg clone https://foss.heptapod.net/pypy/cffi``